summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-31 20:21:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-31 20:25:54 +0200
commitb29cb5b37cc7bdf259d9d8704125d57de5046635 (patch)
treefda4289f66d02178550dbd2b539427e80115c836 /dev-python/pip-run
parentdev-python/autocommand: new package, add 2.2.1_p20211118 (diff)
downloadgentoo-b29cb5b37cc7bdf259d9d8704125d57de5046635.tar.gz
gentoo-b29cb5b37cc7bdf259d9d8704125d57de5046635.tar.bz2
gentoo-b29cb5b37cc7bdf259d9d8704125d57de5046635.zip
dev-python/pip-run: new package, add 8.8.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/metadata.xml13
-rw-r--r--dev-python/pip-run/pip-run-8.8.0.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
new file mode 100644
index 000000000000..919e3b249dd7
--- /dev/null
+++ b/dev-python/pip-run/Manifest
@@ -0,0 +1 @@
+DIST pip-run-8.8.0.gh.tar.gz 22145 BLAKE2B 18b915a29a1767022a609e356005e87f035c3d9bab6dd5ab44f9f42668f4d64c4ee5360cb92b217aa2b7b94e0fbfdb5f0e494e668d9bed8badc38ab36cced353 SHA512 301083a34dea08035819024f17d8108f9751a765cdfc8f2e273b948c7746111efedd80765a63c3ac145bdf7d2b41c9a0b2b20286181c4c94cbc5501fb81eb74d
diff --git a/dev-python/pip-run/metadata.xml b/dev-python/pip-run/metadata.xml
new file mode 100644
index 000000000000..00337c32ff89
--- /dev/null
+++ b/dev-python/pip-run/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pip-run</remote-id>
+ <remote-id type="github">jaraco/pip-run</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pip-run/pip-run-8.8.0.ebuild b/dev-python/pip-run/pip-run-8.8.0.ebuild
new file mode 100644
index 000000000000..accd1c717974
--- /dev/null
+++ b/dev-python/pip-run/pip-run-8.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="https://pypi.org/project/pip-run/
+ https://github.com/jaraco/pip-run"
+SRC_URI="
+ https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Needs network access, and another test dep nbformat
+ pip_run/tests/test_scripts.py
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}