summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:41:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:52:03 +0100
commite94b73366a63094d25a51bc079b3bb32d9ef8fb4 (patch)
tree7f208c9edb97e5fcf7859d26ee651ff3c8816f49 /dev-python/podman-py
parentdev-python/python-utils: Bump to 3.5.2 (diff)
downloadgentoo-e94b73366a63094d25a51bc079b3bb32d9ef8fb4.tar.gz
gentoo-e94b73366a63094d25a51bc079b3bb32d9ef8fb4.tar.bz2
gentoo-e94b73366a63094d25a51bc079b3bb32d9ef8fb4.zip
dev-python/podman-py: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podman-py')
-rw-r--r--dev-python/podman-py/Manifest1
-rw-r--r--dev-python/podman-py/podman-py-4.4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/podman-py/Manifest b/dev-python/podman-py/Manifest
index 694f0c6120ab..5dc66a78d649 100644
--- a/dev-python/podman-py/Manifest
+++ b/dev-python/podman-py/Manifest
@@ -1 +1,2 @@
DIST podman-py-4.3.0.gh.tar.gz 177403 BLAKE2B 549d3aba023423e5ae45fb04e0ec67bdb8ef6cdbe3e4fe6dec2f5e4d1f1df08828aed00aa83b7ad26f6c88ba225211a108ff67ba28e0003827c00ce3c32428ea SHA512 4e7c1f23d7baf425079689635c2b468871eff7f898f150b9244faf3d199a1cf2544aee1f633e431cd40701fbaaa41861d894e72486a38c6a198fd2c33691b826
+DIST podman-py-4.4.0.gh.tar.gz 177587 BLAKE2B 92d2a45a20304be648247fe8c95ab7ed84795e419d79fc731a6be4f228851b10324546b9cd14f9235a3972fd9258d50b2512216121c0fef59c0eb66d7c12c91c SHA512 47b4157fd9e6d54171f6f970012e828f877c66c4fabe4f30ad93974945b9e35fa7084c2908efca42c8b71a8d9f25e7a29a624152ce7bea1eebafcaa3700cb967
diff --git a/dev-python/podman-py/podman-py-4.4.0.ebuild b/dev-python/podman-py/podman-py-4.4.0.ebuild
new file mode 100644
index 000000000000..a7a8eed2e9b6
--- /dev/null
+++ b/dev-python/podman-py/podman-py-4.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/
+"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}