summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-26 07:56:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-26 07:57:41 +0100
commit1840fa88f133431197ad4f656b0789372d19020a (patch)
treed648b3435f268a5afef09ff1bcdd98d7d8a69670 /dev-python/pplpy
parentdev-python/phonenumbers: Bump to 8.13.33 (diff)
downloadgentoo-1840fa88f133431197ad4f656b0789372d19020a.tar.gz
gentoo-1840fa88f133431197ad4f656b0789372d19020a.tar.bz2
gentoo-1840fa88f133431197ad4f656b0789372d19020a.zip
dev-python/pplpy: Fix building docs
We need to call sphinx via `python -m` and to remove source `ppl` directory, to ensure that the correct site-packages are used. Closes: https://bugs.gentoo.org/927771 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/pplpy-0.8.10.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/pplpy/pplpy-0.8.10.ebuild b/dev-python/pplpy/pplpy-0.8.10.ebuild
index 66bea27018d0..377d267f9379 100644
--- a/dev-python/pplpy/pplpy-0.8.10.ebuild
+++ b/dev-python/pplpy/pplpy-0.8.10.ebuild
@@ -35,15 +35,9 @@ BDEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-distutils_enable_sphinx docs/source
-
python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all(){
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
+ rm -r ppl || die
+ use doc && build_sphinx docs/source
}
python_test(){