summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 08:17:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 08:23:41 +0100
commitbba342c60b31a0470ff313c9e649afa149c4a6d2 (patch)
treeb607402064a317f6e2edd259fb849fa7c6ea0cf6 /dev-python/prettytable
parentdev-python/boto3: Bump to 1.17.19 (diff)
downloadgentoo-bba342c60b31a0470ff313c9e649afa149c4a6d2.tar.gz
gentoo-bba342c60b31a0470ff313c9e649afa149c4a6d2.tar.bz2
gentoo-bba342c60b31a0470ff313c9e649afa149c4a6d2.zip
dev-python/prettytable: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-2.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 2c9448eed920..f0e362fe1dcd 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
DIST prettytable-2.0.0.tar.gz 43072 BLAKE2B 2293d0377f0bbef925014812cf0cd3702ef4f651927302012df44e829dd9ea249d03ddaee32f9313f3d001900e92df9a3be8812c8fc573624d308fa5c40a858a SHA512 b7c47df7d85a91e9518dea8dafcb27037e5cde81f59dd2b9e9468ae44b18431dd7d943fed487d5713e2c5aa25df76a8eb6587d045f73b8f25f53715a8a2085fc
+DIST prettytable-2.1.0.tar.gz 43306 BLAKE2B e2085003f2720d573e19fb2b03c8aa98262ec9e7a3f7d0a20474cad2fab374a91664bb513d8158cd612e58a47917c3ebe8b43798272f38c182f6cc2472918f55 SHA512 8eaad22c66299ca3f66cc167e1a94aa41e3b2699da4ff48a0e81927ee8cc623d3147ae29a0bef92370d07d6a7fb6b1eac535fca7090562419aed219b9483edd5
diff --git a/dev-python/prettytable/prettytable-2.1.0.ebuild b/dev-python/prettytable/prettytable-2.1.0.ebuild
new file mode 100644
index 000000000000..f5e4ead55000
--- /dev/null
+++ b/dev-python/prettytable/prettytable-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )"
+
+distutils_enable_tests --install pytest