summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:23:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:21 +0100
commit450ef67fd8c9d401ae45cc93706ed490f98da2ba (patch)
treefecdd5577a7fbeb1fee739f67d603812297d3047 /dev-python/proto-plus
parentdev-python/googleapis-common-protos: Bump to 1.58.0 (diff)
downloadgentoo-450ef67fd8c9d401ae45cc93706ed490f98da2ba.tar.gz
gentoo-450ef67fd8c9d401ae45cc93706ed490f98da2ba.tar.bz2
gentoo-450ef67fd8c9d401ae45cc93706ed490f98da2ba.zip
dev-python/proto-plus: Bump to 1.22.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.22.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 82c6b8b2b57a..39168847124e 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-1.22.1.gh.tar.gz 69507 BLAKE2B b71c263270dde979da0e050a21db258366ca5ddfaed5f8fb78e53444454a123d171019801873d1662ca73a89f079fa1c4cb7c58d34053cabb528015c0d742183 SHA512 2fb5dcb6124d6e2aab010089f4ad138de5cd819d4e67c2b9a6d7044a3d7677ca6e5e37e9aa0ee9edb262c52724dfd2dc05592c489df66d3cafbdf51f13644c7e
+DIST proto-plus-1.22.2.gh.tar.gz 69899 BLAKE2B ad485b04e4187dd5e33259e314d807ad5541c2ddf4fb8e0a85deb195c7643194d34101428fb4fcb7dd692d60e4dd4c4037f821b8fb0049a6e36e002ce870e48a SHA512 bacb8f285417bf0e4d20898c9bb2563e16204b09fc6fb92aadfcd67ad12df388681658eaaacd9b945f4d0ad7e2ce9b95dfc938f5ccc0c4419805c53ed837b2d7
diff --git a/dev-python/proto-plus/proto-plus-1.22.2.ebuild b/dev-python/proto-plus/proto-plus-1.22.2.ebuild
new file mode 100644
index 000000000000..abaa5c89c162
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.22.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme