summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-21 16:01:38 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-21 16:01:38 +0200
commit41982a2524f2d0f8fba36aee3eac0b879f5cc20b (patch)
treed309529afb335a15e108f9f18633dae2b08ed99f /dev-python/pycobertura/pycobertura-0.10.0.ebuild
parentapp-text/xdvik: Honour SYSROOT to fix cross compilation. (diff)
downloadgentoo-41982a2524f2d0f8fba36aee3eac0b879f5cc20b.tar.gz
gentoo-41982a2524f2d0f8fba36aee3eac0b879f5cc20b.tar.bz2
gentoo-41982a2524f2d0f8fba36aee3eac0b879f5cc20b.zip
dev-python/pycobertura: Initial version
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/pycobertura/pycobertura-0.10.0.ebuild')
-rw-r--r--dev-python/pycobertura/pycobertura-0.10.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycobertura/pycobertura-0.10.0.ebuild b/dev-python/pycobertura/pycobertura-0.10.0.ebuild
new file mode 100644
index 000000000000..4eb805a2a6dd
--- /dev/null
+++ b/dev-python/pycobertura/pycobertura-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="Cobertura coverage parser that can diff reports and show coverage progress"
+HOMEPAGE="https://github.com/SurveyMonkey/pycobertura"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}