summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-05-26 17:00:22 +0200
committerDavid Seifert <soap@gentoo.org>2019-05-26 17:00:22 +0200
commitaac155cbcde7b8fb16f5b7cbb41a6759520bea74 (patch)
tree3761de9026785c69d0c90caf52c1f8a8da8bd270 /dev-python/pygame_sdl2
parentdev-lang/rust: restore patch for LibreSSL 2.9.x support (diff)
downloadgentoo-aac155cbcde7b8fb16f5b7cbb41a6759520bea74.tar.gz
gentoo-aac155cbcde7b8fb16f5b7cbb41a6759520bea74.tar.bz2
gentoo-aac155cbcde7b8fb16f5b7cbb41a6759520bea74.zip
dev-python/pygame_sdl2: [QA] Fix virtual/jpeg SLOT
* Don't use the binary compatibility slot for a source package. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pygame_sdl2')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild29
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r2.ebuild (renamed from dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild)27
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r2.ebuild (renamed from dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild)16
3 files changed, 35 insertions, 37 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
index 2c7b47dbd37e..dc01aea24405 100644
--- a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
inherit distutils-r1
@@ -14,31 +14,26 @@ SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
LICENSE="LGPL-2.1 ZLIB"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-DEPEND="
+RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/libpng:0
- media-libs/libsdl2[video]
- media-libs/sdl2-image[png,jpeg]
- >=media-libs/sdl2-mixer-2.0.2
- media-libs/sdl2-ttf
- virtual/jpeg:62
-"
-RDEPEND="${DEPEND}"
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ media-libs/sdl2-mixer:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
-PATCHES=( "${FILESDIR}/pygame_sdl2-6.99.12.4-mixer.patch" )
-
# PyGame distribution for this version has some pregenerated files;
# we need to remove them
python_prepare_all()
{
- rm -r "${S}"/gen{,3} || die
+ rm -r gen{,3} || die
distutils-r1_python_prepare_all
}
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r2.ebuild
index 372e1a7f714a..8f6ab7706900 100644
--- a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
inherit distutils-r1
@@ -14,26 +14,29 @@ SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
LICENSE="LGPL-2.1 ZLIB"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/libpng:0
- media-libs/libsdl2[video]
- media-libs/sdl2-image[png,jpeg]
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- virtual/jpeg:62
-"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ >=media-libs/sdl2-mixer-2.0.2:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+PATCHES=( "${FILESDIR}/pygame_sdl2-6.99.12.4-mixer.patch" )
+
# PyGame distribution for this version has some pregenerated files;
# we need to remove them
python_prepare_all()
{
- rm -r "${S}"/gen{,3} || die
+ rm -r gen{,3} || die
distutils-r1_python_prepare_all
}
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r2.ebuild
index fbf4027ae86e..8312566925b3 100644
--- a/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r2.ebuild
@@ -15,14 +15,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/libpng:0
- media-libs/libsdl2[video]
- media-libs/sdl2-image[png,jpeg]
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- virtual/jpeg:62
-"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ media-libs/sdl2-mixer:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]"