summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-13 05:14:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-13 05:14:59 +0100
commit174ad003cb0c0b6d65741c4db428fa9485d54d58 (patch)
tree08df1d1f65e92a30188917223d536bfae8a09965 /dev-python/pyghmi
parentdev-python/urwid: Bump to 2.5.3 (diff)
downloadgentoo-174ad003cb0c0b6d65741c4db428fa9485d54d58.tar.gz
gentoo-174ad003cb0c0b6d65741c4db428fa9485d54d58.tar.bz2
gentoo-174ad003cb0c0b6d65741c4db428fa9485d54d58.zip
dev-python/pyghmi: Bump to 1.5.67
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.67.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index e1bf5b914237..54b2172677a2 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,2 +1,3 @@
DIST pyghmi-1.5.65.tar.gz 256355 BLAKE2B c3e64fd7f39d1fc785cc4b337ff4f5578978b79aeecb6c77d1291a1d54e5bc0b566e88af149b68ded75cac7c4ec9f89401cf8941fe4710514fb8af19bce82faa SHA512 a82db08e93b68633403a19b86dfcb0951065165846d1fd3a4b92e38438cdcb88f9387480f7a5c2d866a0e7d4488d35396de6e5ee73d7ebbdf78055b6390eb708
DIST pyghmi-1.5.66.tar.gz 256768 BLAKE2B 4be0359fb4a35611867f2aa68f558e94bf2d5402cb4ceb20d966d97d3b758ba8b25d19c438ff4e30b34fe0d0cc369e3803c5ccf71f101ac741587138832ff367 SHA512 87bc0ec1e79241416c87a6eee8a730bb253242f6ef8c64e0fb24f2d443f66682659a3eaceebfdaaa618393c96118c26695ffabec8afc82226136100d569db81d
+DIST pyghmi-1.5.67.tar.gz 256905 BLAKE2B 497193e057a4a2e285ba109fc58cf59c77dbef69c73abeabe7fa88629af7c3c961488cd0df173edb81a4b6574893d4db4c43bcd7d8f8c93b5c10bdf768ab9e2e SHA512 db2e16a873db52ebffbfbdf4b03ba22eca462ecf498b0704602cf52257fff2021d0cd7f71161377a3e87029771c2cbb0f8090b215f7da2efeecb8bfaadaadd82
diff --git a/dev-python/pyghmi/pyghmi-1.5.67.ebuild b/dev-python/pyghmi/pyghmi-1.5.67.ebuild
new file mode 100644
index 000000000000..f4adcb0eed3b
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.67.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest