summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-04 04:25:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-04 04:41:53 +0200
commitf845e48c0906d901d5caee857bd5f3668cda621c (patch)
treef8c6fa5bd18fa5d60eeb122763c47d6efa73bcd3 /dev-python/pyghmi
parentdev-util/stripe-mock: Bump to 0.169.0 (diff)
downloadgentoo-f845e48c0906d901d5caee857bd5f3668cda621c.tar.gz
gentoo-f845e48c0906d901d5caee857bd5f3668cda621c.tar.bz2
gentoo-f845e48c0906d901d5caee857bd5f3668cda621c.zip
dev-python/pyghmi: Bump to 1.5.62
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.62.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 4f4e9abd7bfc..c47cb77c8770 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.61.tar.gz 252058 BLAKE2B 468805d478f665b1e516f9362c00519a5d82965158f5e829610eff81addf92860d69273f1e4d9708c245e33956a8e239e873b86a37f58c3d65a049bdd1a7a183 SHA512 783491d5ec76568a8c07c85d24e013aa9b532e06269c0c6efcddd6362fc184545fe8ce22c0ac5b447171163c88ec4656cea7435fa517e8dd5dc53b460bf8368e
+DIST pyghmi-1.5.62.tar.gz 254190 BLAKE2B 1dd80e75688b66413c2b4168c082bb34a2f92123b8f5599794948e92b23defaab4a12885dba7bfefc1c4a0ba8bc21690dba0836cf3a2c38363c1c3c67672aca8 SHA512 d1c68f6c153948c5532581dd869b59e462be9027bb8c935147a61091e9c5f64b76f33119181f87ada755857fac6cd7671583dd737340b222b04d18e2db17e7a5
diff --git a/dev-python/pyghmi/pyghmi-1.5.62.ebuild b/dev-python/pyghmi/pyghmi-1.5.62.ebuild
new file mode 100644
index 000000000000..385e2b0dd253
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.62.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest