summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-13 08:33:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-13 09:09:19 +0100
commitf39ecd18fc456d3226d892ce2f2e366e643af10a (patch)
tree22fadad6bbe25450369647dcdc248d8cfc469b19 /dev-python/pyhamcrest
parentdev-python/setuptools: Bump to 59.6.0 (diff)
downloadgentoo-f39ecd18fc456d3226d892ce2f2e366e643af10a.tar.gz
gentoo-f39ecd18fc456d3226d892ce2f2e366e643af10a.tar.bz2
gentoo-f39ecd18fc456d3226d892ce2f2e366e643af10a.zip
dev-python/pyhamcrest: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest1
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index a5c41a927641..a39a9730da15 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1 +1,2 @@
DIST PyHamcrest-2.0.2.gh.tar.gz 55491 BLAKE2B 749f227b8cb1180a64e24cdbf97b6f610b9871b21215a761642d19fdd43ad8e175718b12cfb0de2cdb5c6ae8c3c5271e04b7c3b489e01ac689769e24202ece56 SHA512 d6e510ca1e6533b425b424d411e23c4ee2a6bad2d635695e4e68f991fbdc57269c3a433361e431cb5dda7891278951d5de7a05f5c1c167714eecdaf74644d1c8
+DIST PyHamcrest-2.0.3.gh.tar.gz 59353 BLAKE2B b393f250f1a5f3f2d3014ae8a6e20ec659e034d8e681fcbb16f4e9fbe69ba7a94ce342a79584cfc99dff6af57e1d9763efd5ff8b5d891951289d9047cab4270c SHA512 4a28c0ae04db11a86c44dff001e919a5bb6b820af8ffd60b1a1f2846f257d79daac76fbdeac4a0039d149e643043258a0685382a3a4b52c6d4586b8be95e1657
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild
new file mode 100644
index 000000000000..d7f479376a63
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}