summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 17:46:17 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-02 23:13:58 +0100
commit7f67525a9b046d7f515e9a5771b477a6946057bb (patch)
tree99fa67deae4dd2f723bb7add3b69fcf859179435 /dev-python/pylint
parentdev-util/conan: Loosen = deps to ~ (diff)
downloadgentoo-7f67525a9b046d7f515e9a5771b477a6946057bb.tar.gz
gentoo-7f67525a9b046d7f515e9a5771b477a6946057bb.tar.bz2
gentoo-7f67525a9b046d7f515e9a5771b477a6946057bb.zip
dev-python/pylint: Clean old up
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest3
-rw-r--r--dev-python/pylint/pylint-1.4.4.ebuild61
-rw-r--r--dev-python/pylint/pylint-1.5.6.ebuild59
-rw-r--r--dev-python/pylint/pylint-1.6.5.ebuild63
-rw-r--r--dev-python/pylint/pylint-1.7.1-r1.ebuild66
5 files changed, 0 insertions, 252 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 3449c4072e78..c8b1726a13f0 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,2 @@
-DIST pylint-1.4.4.tar.gz 342461 BLAKE2B 5d9be4634e87305f38710dd85601ba385262754dcd63b68bb779a6c9a655d048ffe3a9ebfd96ea8fbf467aca40dcda449076ffe882e65d3605e4964221d00331 SHA512 bcbf5439628a071055cea441455f6c0fe0cbfae2617c473bc376b880421f17f78653901d7cf49950653436a0991a3bafbc2df15744ff24a3b059de53e518b331
-DIST pylint-1.5.6.tar.gz 425251 BLAKE2B ffcf510681bcbbae0b6ac41e28f06132d026a8318cf989681262b7a8d03f97c207a381315a7c7af6ede6cea6c75dfba09d8ced8893277012addf9ce9829300eb SHA512 569a747a0d2c4f60ff2c16af6117f501fa1a9a6546fcc1228909b23024e2bc05951985acf56249919b67b11f161cb1855321115ad9fd7a7c409b71faa5dd8278
DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc9406666626d62764f476bbc024e34fea06883fae829fe6617ebfffde54dfa5600c140b9a25e6c9633f48d76f5c331 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410
-DIST pylint-1.7.1.tar.gz 489108 BLAKE2B 7c14e2f2a3d85a33b98a1cacc487d75f4c2362e158f28df773f4dad4e06c88ff783dfb6f898a6c3bf75d73e7915610d6d5e45b007bc0723405282481e3a61879 SHA512 e0efbaad3ca3205a2e2e1e4bc444e635540db12e139e008ff2ca8b454dd117488e767f070126074389d6d82c17622da747b9a948711225246877fed69ac81148
DIST pylint-1.7.2.tar.gz 488628 BLAKE2B 6f2902bdd18939f251515d652d2e9df43162c1b0c27c2e2ed7392ee77be9e7f81bbd62cede4f2eb1e7aa646bf47c48b01436e04cbf46a20458a1c89eff752d9d SHA512 268f141f017fa4df6024596bcf1dfb32a578e9459864e2ace8c2725c8f5e117e0b01d9d745f1632bb43102a01f7075dc3fb69b839b79371f7df47740a56fc1cb
diff --git a/dev-python/pylint/pylint-1.4.4.ebuild b/dev-python/pylint/pylint-1.4.4.ebuild
deleted file mode 100644
index 30d279882005..000000000000
--- a/dev-python/pylint/pylint-1.4.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-RESTRICT="test" # needs pygtk
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/project/pylint https://pypi.python.org/pypi/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
- >=dev-python/astroid-1.3.6[${PYTHON_USEDEP}]
- <dev-python/astroid-1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- # Test suite appears not to work under Python 3.
- # https://bitbucket.org/logilab/pylint/issue/240/
- local msg="Test suite broken with ${EPYTHON}"
- if python_is_python3; then
- einfo "${msg}"
- return 0
- fi
-
- pytest || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
-}
diff --git a/dev-python/pylint/pylint-1.5.6.ebuild b/dev-python/pylint/pylint-1.5.6.ebuild
deleted file mode 100644
index e6fd948fc773..000000000000
--- a/dev-python/pylint/pylint-1.5.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- http://www.logilab.org/project/pylint
- https://pypi.python.org/pypi/pylint
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/astroid-1.4.5[${PYTHON_USEDEP}]
- <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-RESTRICT="test" # multiple failures
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- ${PYTHON} \
- -m unittest discover \
- -s pylint/test/ -p "*test_*".py \
- --verbose || die
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
-}
diff --git a/dev-python/pylint/pylint-1.6.5.ebuild b/dev-python/pylint/pylint-1.6.5.ebuild
deleted file mode 100644
index b8ad4438224f..000000000000
--- a/dev-python/pylint/pylint-1.6.5.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- http://www.logilab.org/project/pylint
- https://pypi.python.org/pypi/pylint
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/astroid-1.4.5[${PYTHON_USEDEP}]
- <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- dev-python/mccabe"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-RESTRICT="test" # multiple failures
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- ${EPYTHON} \
- -m unittest discover \
- -s pylint/test/ -p "*test_*".py \
- --verbose || die
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
-}
diff --git a/dev-python/pylint/pylint-1.7.1-r1.ebuild b/dev-python/pylint/pylint-1.7.1-r1.ebuild
deleted file mode 100644
index d2b95b6b8b01..000000000000
--- a/dev-python/pylint/pylint-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- http://www.logilab.org/project/pylint
- https://pypi.python.org/pypi/pylint
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/astroid-1.5.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- dev-python/mccabe[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
- dev-python/configparser[${PYTHON_USEDEP}]' -2)"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # remove unused dep
- sed -i -e '/pytest-runner/d' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
-}