summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-03-07 21:00:17 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2021-03-08 06:34:25 +0100
commit93513177830f770fb90e7978089d64df94553bff (patch)
treec756cbc3a10fc5c1e9111f37ab9a8e406ef29ce9 /dev-python/pynest2d
parentdev-util/meson: Stabilize 0.56.2 ppc, #774684 (diff)
downloadgentoo-93513177830f770fb90e7978089d64df94553bff.tar.gz
gentoo-93513177830f770fb90e7978089d64df94553bff.tar.bz2
gentoo-93513177830f770fb90e7978089d64df94553bff.zip
dev-python/pynest2d: boost 1.75 compatibility
Closes: https://bugs.gentoo.org/764566 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/pynest2d')
-rw-r--r--dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch11
-rw-r--r--dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild30
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch b/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch
new file mode 100644
index 000000000000..1fe895892de2
--- /dev/null
+++ b/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,7 +17,7 @@ find_package(Boost REQUIRED) # Dependency of libnest2d.
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DLIBNEST2D_GEOMETRIES_clipper -DLIBNEST2D_OPTIMIZERS_nlopt -DLIBNEST2D_THREADING_std") # Tell libnest2d to use Clipper and NLopt, and standard threads.
+
+ # Some build options.
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 14)
+ if(APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
+ endif()
diff --git a/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild b/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..b2b6ecd0a450
--- /dev/null
+++ b/dev-python/pynest2d/pynest2d-4.8.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Python bindings for libnest2d"
+HOMEPAGE="https://github.com/Ultimaker/pynest2d"
+SRC_URI="https://github.com/Ultimaker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libnest2d
+ $(python_gen_cond_dep 'dev-python/sip[${PYTHON_MULTI_USEDEP}]')
+ "
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-required-flags-from-Libnest2D-target.patch
+ "${FILESDIR}"/${P}-fix-cpp-version.patch
+)