summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 04:26:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 04:26:22 +0200
commitd942d80aeec6b5ff05c5cdc944f123175bf8e2ca (patch)
tree3ad6be380cbfb61234955419f0790e908c4fe016 /dev-python/pyopencl
parentdev-libs/c-blosc2: Bump to 2.10.2 (diff)
downloadgentoo-d942d80aeec6b5ff05c5cdc944f123175bf8e2ca.tar.gz
gentoo-d942d80aeec6b5ff05c5cdc944f123175bf8e2ca.tar.bz2
gentoo-d942d80aeec6b5ff05c5cdc944f123175bf8e2ca.zip
dev-python/pyopencl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2023.1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 676bb4c02d92..581263015123 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
DIST pyopencl-2023.1.1.tar.gz 472723 BLAKE2B 4960db0b9096ef624f0459f6711a6d1fc4561599f96c3b01c5efe3c183c8cc4284b63038b2a5e98d43c194a8e5ce3331886f675c0bc5f44073bc353675400985 SHA512 50c23132028bb2c35816b6c83c054eaf929d333fbb172230e0d696a5e6103ad6ee6ccbbbd0b5d3d2d3c5f02505340a885422097eccecb1bf51845658c7938c8f
-DIST pyopencl-2023.1.tar.gz 472581 BLAKE2B bfa25646b00b8d5c1a2fb7b98c18383e3013b9aa1573dc1bcbc1e056d3bd50d48fb35b7b74c4d87c079fe9334817ff325edd235bdd0de610373850c3ab057773 SHA512 3a6c61715338b31f9e9c3b9c8afe029e63d2689f9d52174c91cfe7383425643b3d08f5c125ab7e24ca776c86ff19d5adb7bfe56f1bd531ba443f99dcf9449244
diff --git a/dev-python/pyopencl/pyopencl-2023.1.ebuild b/dev-python/pyopencl/pyopencl-2023.1.ebuild
deleted file mode 100644
index c5b324926a54..000000000000
--- a/dev-python/pyopencl/pyopencl-2023.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="
- https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64"
-IUSE="examples opengl"
-
-# Running tests on GPUs requires both appropriate hardware and additional permissions
-# having been granted to the user running them. Testing on CPUs with dev-libs/pocl
-# is in theory possible but has been found to be very fragile, see e.g. Bug #872308.
-RESTRICT="test"
-
-COMMON=">=virtual/opencl-2"
-# libglvnd is only needed for the headers
-DEPEND="${COMMON}
- opengl? ( media-libs/libglvnd )"
-RDEPEND="${COMMON}
- >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- test? ( dev-libs/pocl )"
-
-distutils_enable_tests pytest
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_test() {
- # Use dev-libs/pocl for testing; ignore any other OpenCL devices that might be present
- local -x PYOPENCL_TEST="portable:pthread"
- # Set the number of threads to match MAKEOPTS
- local -x POCL_MAX_PTHREAD_COUNT=$(makeopts_jobs)
- # Change to the 'test' directory so that python does not try to import pyopencl from the source directory
- # (Importing from the source directory fails, because the compiled '_cl' module is only in the build directory)
- pushd test >/dev/null || die
- epytest
- popd >/dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}