summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-24 18:39:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-25 23:49:10 +0200
commit7bbc0b0897116daafbf21c73178d641bb20f46a5 (patch)
treef29fde739790a3d97a3e4c09ed5bbe1b55f6e0b8 /dev-python/pypy
parentdev-python/pypy: Upstream deprecated asmgc, and defaults to shadowstack (diff)
downloadgentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.tar.gz
gentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.tar.bz2
gentoo-7bbc0b0897116daafbf21c73178d641bb20f46a5.zip
dev-python/pypy: Switch 9999 to cpy2.7.13 patchset
Use the patchset from CPython 2.7.13 to avoid keeping old patches around. Disable the Turkish locale patch since it now alters the C sources of CPython -- we need to figure out if pypy needs similar alteration at all, and port it if necessary.
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/Manifest1
-rw-r--r--dev-python/pypy/pypy-9999.ebuild7
2 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pypy/Manifest b/dev-python/pypy/Manifest
index d51c126c4f85..23e3ef85d482 100644
--- a/dev-python/pypy/Manifest
+++ b/dev-python/pypy/Manifest
@@ -1,2 +1,3 @@
DIST pypy2-v5.6.0-src.tar.bz2 18388539 SHA256 7411448045f77eb9e087afdce66fe7eafda1876c9e17aad88cf891f762b608b0 SHA512 a92ef611ae2417aaa202b9f5c75dd86e82fc2549e53bab3164cccff37d131542bc71cbce6aaedf428d3dfc7d59a2d3b3a5ed03e3a3439628f29d43c4d30a64de WHIRLPOOL 896894225407f8cd462b094d77723880f6a423d60a79e5d3cf4e0804737fdd0337fc668b05573902fe81f826798b2046cb115c8d230f0810ec0ad2508590ee4a
DIST python-gentoo-patches-2.7.11-0.tar.xz 12916 SHA256 e14b47bb1fd64d366d7dfb8339cc2cbf4a53fc288b11dd83f575eb36a8a6408d SHA512 f0447bb699a163afc08df39b111394377539935546ae23732d7239e78d2bff0c04bc94949f86aef0c1be83736127dbd25c2c531e49befed2d638c3cd4940ac52 WHIRLPOOL 305992849d9d244da1e308e739c9bf62a3ef5c74eb65c765bdc666fb5767eb16c7a609f7c442c17da17f76c3ab81e4b09fa8c21e43f89366539a6a9d656bea77
+DIST python-gentoo-patches-2.7.13-0.tar.xz 13292 SHA256 271835eb36125d09cc5e904ef23a5263acd8e5f513202a8d4f8a9a0f64fc80a8 SHA512 d70f6baba1a465a752c515e33dfdee2a5cc75400fadfb8ea0bd1e82d50089abdf02d7726c697850dc47de2054aa494bbdc08de2673c260b54e609f29dab259ad WHIRLPOOL 6a6d8b099fa814839bf5b3455b3889205c649ef522b35c3a501831d63d0e916d7747b83ac9b8991f8f8c34b328478d84cf7a12a32161ce0fec37204f9c019e2d
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index e3f07058ffb0..4cda2cf09a0e 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -8,13 +8,13 @@ EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
inherit check-reqs eutils mercurial multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
# note: remember to update this to newest dev-lang/python:2.7 on bump
-CPY_PATCHSET_VERSION="2.7.11-0"
+CPY_PATCHSET_VERSION="2.7.13-0"
MY_P=pypy2-v${PV}
DESCRIPTION="A fast, compliant alternative implementation of the Python language"
HOMEPAGE="http://pypy.org/"
SRC_URI="
- https://dev.gentoo.org/~djc/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
+ https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
LICENSE="MIT"
# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
@@ -103,8 +103,9 @@ src_prepare() {
# apply CPython stdlib patches
pushd lib-python/2.7 > /dev/null || die
+ # TODO: cpy turkish locale patch now fixes C code
+ # probably needs better port to pypy, if it is broken there
epatch "${FILESDIR}"/5.6.0_all_distutils_cxx.patch \
- "${WORKDIR}"/patches/22_all_turkish_locale.patch \
"${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
popd > /dev/null || die