summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-11 08:20:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-11 08:22:22 +0200
commitfe9b3c589dc0033b806bf3632e4fa9a445a696cd (patch)
tree3dfc93a5ea718ed0f90cc116fcaa9340532a2a1b /dev-python/pytables
parentdev-python/h5py: Backport cython-3 fix (diff)
downloadgentoo-fe9b3c589dc0033b806bf3632e4fa9a445a696cd.tar.gz
gentoo-fe9b3c589dc0033b806bf3632e4fa9a445a696cd.tar.bz2
gentoo-fe9b3c589dc0033b806bf3632e4fa9a445a696cd.zip
dev-python/pytables: Backport cython-3 fix
Closes: https://bugs.gentoo.org/898710 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/files/pytables-3.8.0-cython3.patch40
-rw-r--r--dev-python/pytables/pytables-3.8.0-r3.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytables/files/pytables-3.8.0-cython3.patch b/dev-python/pytables/files/pytables-3.8.0-cython3.patch
new file mode 100644
index 000000000000..9ad0b72d224a
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.8.0-cython3.patch
@@ -0,0 +1,40 @@
+From a70e36f0b0d4fb15b0b50e7ca513c4e4452767cc Mon Sep 17 00:00:00 2001
+From: Matus Valo <matusvalo@gmail.com>
+Date: Wed, 15 Mar 2023 22:49:07 +0100
+Subject: [PATCH] Fix build errors when compiled using cython 3.0.0b1.
+
+---
+ pyproject.toml | 2 +-
+ tables/tableextension.pyx | 2 +-
+ tables/utilsextension.pyx | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tables/tableextension.pyx b/tables/tableextension.pyx
+index 8f3bb01b..4a50c6ab 100644
+--- a/tables/tableextension.pyx
++++ b/tables/tableextension.pyx
+@@ -37,7 +37,7 @@ from .utils import SizeType
+ from .utilsextension cimport get_native_type, cstr_to_pystr
+
+ # numpy functions & objects
+-from hdf5extension cimport Leaf
++from .hdf5extension cimport Leaf
+ from cpython cimport PyErr_Clear
+ from libc.stdio cimport snprintf
+ from libc.stdlib cimport malloc, free
+diff --git a/tables/utilsextension.pyx b/tables/utilsextension.pyx
+index 5b16dcd3..664e1ea5 100644
+--- a/tables/utilsextension.pyx
++++ b/tables/utilsextension.pyx
+@@ -344,7 +344,7 @@ except ImportError:
+ #---------------------------------------------------------------------
+
+ # Error handling helpers
+-cdef herr_t e_walk_cb(unsigned n, const H5E_error_t *err, void *data) with gil:
++cdef herr_t e_walk_cb(unsigned n, const H5E_error_t *err, void *data) noexcept with gil:
+ cdef object bt = <object>data # list
+ #cdef char major_msg[256]
+ #cdef char minor_msg[256]
+--
+2.40.1
+
diff --git a/dev-python/pytables/pytables-3.8.0-r3.ebuild b/dev-python/pytables/pytables-3.8.0-r3.ebuild
index c2dfebf6f12b..4eb70e76b350 100644
--- a/dev-python/pytables/pytables-3.8.0-r3.ebuild
+++ b/dev-python/pytables/pytables-3.8.0-r3.ebuild
@@ -52,6 +52,7 @@ python_prepare_all() {
local PATCHES=(
"${FILESDIR}"/${P}-blosc2.patch
"${FILESDIR}"/${P}-optional-cpuinfo.patch
+ "${FILESDIR}"/${P}-cython3.patch
)
export PYTABLES_NO_EMBEDDED_LIBS=1