summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-19 09:20:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-19 10:36:01 +0100
commitaa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76 (patch)
treeed45b7b782947952a3a4967e3089f547d402948f /dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild
parentsci-libs/libigl: add 2.4.0 (diff)
downloadgentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.tar.gz
gentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.tar.bz2
gentoo-aa7d4021e58a4c2814b6b4c87ec8f1c3f76c0b76.zip
dev-python/pytest-flake8: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild')
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild
new file mode 100644
index 000000000000..80ff41385fa4
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for flake8"
+HOMEPAGE="
+ https://github.com/tholo/pytest-flake8/
+ https://pypi.org/project/pytest-flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/flake8-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p flake8
+}