summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 23:06:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-08 00:22:31 +0200
commit632119a7e17a8e1bebe62be56ea36c37b98cdddb (patch)
tree1e3e07f368644fb39d3b9bfc001faf4183c19827 /dev-python/pytest-freezegun
parentdev-python/freezegun: Enable python3.10 (diff)
downloadgentoo-632119a7e17a8e1bebe62be56ea36c37b98cdddb.tar.gz
gentoo-632119a7e17a8e1bebe62be56ea36c37b98cdddb.tar.bz2
gentoo-632119a7e17a8e1bebe62be56ea36c37b98cdddb.zip
dev-python/pytest-freezegun: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-freezegun')
-rw-r--r--dev-python/pytest-freezegun/pytest-freezegun-0.4.2.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/pytest-freezegun/pytest-freezegun-0.4.2.ebuild b/dev-python/pytest-freezegun/pytest-freezegun-0.4.2.ebuild
index 3660463cacea..ebd2b8b853b5 100644
--- a/dev-python/pytest-freezegun/pytest-freezegun-0.4.2.ebuild
+++ b/dev-python/pytest-freezegun/pytest-freezegun-0.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Easily freeze time in pytest test + fixtures"
@@ -20,9 +20,4 @@ RDEPEND="
dev-python/freezegun[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]"
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest