summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-27 04:18:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-27 04:36:58 +0100
commit3304f71023a403fb6d5624e32183890bce3f0768 (patch)
treea89215da42130db49200454f239233c5a6a4e122 /dev-python/pytest-plus
parentdev-python/coverage: Remove old (diff)
downloadgentoo-3304f71023a403fb6d5624e32183890bce3f0768.tar.gz
gentoo-3304f71023a403fb6d5624e32183890bce3f0768.tar.bz2
gentoo-3304f71023a403fb6d5624e32183890bce3f0768.zip
dev-python/pytest-plus: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.7.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index 3934f0ccd79d..1f84888ea7c4 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1 +1,2 @@
DIST pytest-plus-0.6.1.tar.gz 12811 BLAKE2B f3892227aa24466b2f2e35187bbf7cf3d67d96745377356b3cc4d295a9fdd8eab8b0fd11b7b5ba96d5209e2bd7440f5e12084cbd83951e3e56cb24c1f2bf6f7b SHA512 4ee2fa8783c36e65616b1fc2e155e4c4898e0a6347058619f9cc0caa319fc62b34304a2ec0377071abef7d2a526c81729f434b228f0fb2b9d1c73fae1169bfde
+DIST pytest-plus-0.7.0.tar.gz 13235 BLAKE2B 87e712a21dcb99b459ac263c46c3dfa1586d6f28404424ea3f02e1436d296b617ead445d35080d014d8385dee56ad2cd579fdf9d52352c7d9e32e31ba90eebdf SHA512 a43b8bd3ea1a7a85e40ea6c180a06a31f5703292758d4c83e1a3f98e0750d75393d9ca8bfb614f1d3a180ee50d18e8162173bfee6b81cf1f7c087aad8e3be3ba
diff --git a/dev-python/pytest-plus/pytest-plus-0.7.0.ebuild b/dev-python/pytest-plus/pytest-plus-0.7.0.ebuild
new file mode 100644
index 000000000000..2e2fb20a9f8c
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-plus/
+ https://pypi.org/project/pytest-plus/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest