summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-19 07:28:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-19 08:03:43 +0200
commitc953101a0300431e2788d7c73eb19436ea43a705 (patch)
tree9a3ecb3acbd12f51d79caac582f5fe1be7019b69 /dev-python/pytest-shell-utilities
parentdev-python/types-setuptools: Bump to 75.2.0.20241019 (diff)
downloadgentoo-c953101a0300431e2788d7c73eb19436ea43a705.tar.gz
gentoo-c953101a0300431e2788d7c73eb19436ea43a705.tar.bz2
gentoo-c953101a0300431e2788d7c73eb19436ea43a705.zip
dev-python/pytest-shell-utilities: Bump to 1.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest1
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index 11c4c0b64fbc..7f4cb9753b15 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,2 +1,3 @@
DIST pytest-shell-utilities-1.9.3.gh.tar.gz 79651 BLAKE2B 1506f7d2fb3b988d55006a8429b6428cb73e969ec72eac5baf944d7e4fc708aaa8e474493ac3e226608c43ece75d2f6070d094f3b656a49bde11bf46a81998d1 SHA512 5ff40043d4f597623bcc61b2c87f00a59fc1882ae6ecda223c82fadc64ae8b5670d07e8e2df54cfcb8b3bdb9483f331a314f4a683760e5ebe843d68ae4067895
DIST pytest-shell-utilities-1.9.4.gh.tar.gz 79652 BLAKE2B 1f584a86397b772396ce0d0d1bbc270fe6803150259f30d20f11d964495eeb13ca39e97d9681cc3dee638ce0cd7afb6fbaa53a741f4fffc148940762f4c52e3f SHA512 2569c22df69ea0408465670e6bc4a981bf751f7943f46bbd01a89cc20ea713a46f74e50730a0d2cb78c8962b3ca3c221cf7c27f95e4fae6c22a0b1ab1f8c68de
+DIST pytest-shell-utilities-1.9.6.gh.tar.gz 79736 BLAKE2B 95c701ffd7b43356f3369d2bab3a8a6aee116b51dd2b78a9fe0e2defe6d86910c69222074ffbd23f6f6aa21f04613f168b9635b481f6b1646f8d8eaf707c9e5e SHA512 829b3c98ac5d9ef2995eb492286eacf84d186bdd75a78ba28e0c5500a0350773fa0d9776043b25eb1951896ec2ca448b43ca340e59bbd5cf27cd392d94408178
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.6.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.6.ebuild
new file mode 100644
index 000000000000..cc996b114679
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}