summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 09:56:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 09:57:49 +0100
commit76bac496e5afbedc0549b4d614ad283ca6282901 (patch)
treec6aea77084be8a5f4fe4a96f706723fae79443c4 /dev-python/pytest-trio
parentdev-python/paramiko: Remove old (diff)
downloadgentoo-76bac496e5afbedc0549b4d614ad283ca6282901.tar.gz
gentoo-76bac496e5afbedc0549b4d614ad283ca6282901.tar.bz2
gentoo-76bac496e5afbedc0549b4d614ad283ca6282901.zip
dev-python/pytest-trio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest1
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index 0670ecdc7a53..1254cd58eb31 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1,2 +1 @@
-DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
DIST pytest-trio-0.8.0.tar.gz 46525 BLAKE2B 54660dc9b021af0ec18eace72f053223d16e89635c74d71329a005e5fee3bf6e2055cc29412d9de7443b2594ee53d68890d1e30ed7c94560c355d4342bb3d035 SHA512 79141021633b7b2d8a840d7eaf6a3447bccd59d1bd4909e7feba88a9ae8244376f281b64fde4333b5a575957e3f73028e389a9abf0d19a35417f15c47eeccd05
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
deleted file mode 100644
index af426052c90a..000000000000
--- a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
-HOMEPAGE="
- https://github.com/python-trio/pytest-trio
- https://pypi.org/project/pytest-trio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/trio-0.15[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/attrs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinxcontrib-trio
-
-python_prepare_all() {
- # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
- mv pytest_trio/_tests/conftest.py conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # disable autoloading pytest-asyncio in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading pytest-trio
- local -x PYTEST_PLUGINS=pytest_trio.plugin
- epytest
-}