summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-29 09:14:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-29 09:26:26 -0400
commit2db404b9f4ba1d0bcd78a582e73b78aa62360f47 (patch)
tree62a48aa7d31c4c78a4fbad0d453f44e173f7b046 /dev-python/pytest-xvfb
parentnet-wireless/gqrx: 2.15.9: Switch IUSE=pulseaudio to media-libs/libpulse (diff)
downloadgentoo-2db404b9f4ba1d0bcd78a582e73b78aa62360f47.tar.gz
gentoo-2db404b9f4ba1d0bcd78a582e73b78aa62360f47.tar.bz2
gentoo-2db404b9f4ba1d0bcd78a582e73b78aa62360f47.zip
dev-python/pytest-xvfb: add 3.0.0
Contains some fixes for python3.12, albeit still a bit to go with dependencies before can try compat here. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest1
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index 20b243acc881..055ea9bcaceb 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1 +1,2 @@
DIST pytest-xvfb-2.0.0.tar.gz 6575 BLAKE2B 7ef37f2d4a1a9d7211a248e67d325f0b722a0a046e6e57ae24cac1b68ead6d11988d49810e15fc41d9a05082d9c318f7569a00ac7574e1a8ee00e76c842cf83b SHA512 de5a98290bfe083cadc732c36a1c5af99b0d618853f8da9a1acd0f0f11a170c54025667c0f13bc0f4ac2657b139306e16d0b3faf00bfdde37eb3df7fb14367ae
+DIST pytest-xvfb-3.0.0.tar.gz 8607 BLAKE2B a1256b121a66c0b778a45f695754363ec241699197000f6237473dc2d54c0eeff499722073b00280ca242d695c192ff4fd985931a42bbb52a0f8e2424867b60a SHA512 9aec1681656badf81fbac3a0d621b163810001e155a1cb8fd35e0f8c8d3ee52556e622adc0468d8e7455b15ba0f5103622fae1aa2493a7053ca78f092e582cf1
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
new file mode 100644
index 000000000000..e9a2d47ef72d
--- /dev/null
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to run Xvfb for tests"
+HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p xvfb --runpytest=subprocess
+}