summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 09:52:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 09:56:51 +0200
commitfa31124dffc6a0de0cb8aa9bfc3371e5a6443898 (patch)
tree8fe923d556db98231ad428abbdfbb9c124d75f15 /dev-python/pytest
parentdev-python/unittest-mixins: Remove python2 (diff)
downloadgentoo-fa31124dffc6a0de0cb8aa9bfc3371e5a6443898.tar.gz
gentoo-fa31124dffc6a0de0cb8aa9bfc3371e5a6443898.tar.bz2
gentoo-fa31124dffc6a0de0cb8aa9bfc3371e5a6443898.zip
dev-python/pytest: Remove tests in <5 to unblock deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-4.6.11.ebuild34
1 files changed, 1 insertions, 33 deletions
diff --git a/dev-python/pytest/pytest-4.6.11.ebuild b/dev-python/pytest/pytest-4.6.11.ebuild
index dde2b477e88a..28a2a2237d43 100644
--- a/dev-python/pytest/pytest-4.6.11.ebuild
+++ b/dev-python/pytest/pytest-4.6.11.ebuild
@@ -15,8 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+RESTRICT="test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.5.0"
@@ -41,23 +40,6 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]"
-# flake cause a number of tests to fail
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- !!dev-python/pytest-aiohttp
- !!dev-python/pytest-asyncio
- !!dev-python/pytest-django
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- )"
-
PATCHES=(
"${FILESDIR}/pytest-4.5.0-strip-setuptools_scm.patch"
"${FILESDIR}/pytest-4.6.10-timeout.patch"
@@ -66,19 +48,5 @@ PATCHES=(
python_prepare_all() {
grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- # Something in the ebuild environment causes this to hang/error.
- # https://bugs.gentoo.org/598442
- rm testing/test_pdb.py || die
-
distutils-r1_python_prepare_all
}
-
-python_test() {
- distutils_install_for_testing
-
- # In v4.1.1, pytest started being picky about its own verbosity options.
- # running pytest on itself with -vv made 3 tests fail. This is why we don't
- # have it below.
- "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
- || die "tests failed with ${EPYTHON}"
-}