summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 17:23:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 18:36:14 +0100
commit59495a0e02d1bd46491b72f6c707d7fca5011863 (patch)
treea46f0e4e2cdb5f5b1cade882bf11742f1495905b /dev-python/python-docs
parentdev-lang/python: Bump to 3.11.2 (diff)
downloadgentoo-59495a0e02d1bd46491b72f6c707d7fca5011863.tar.gz
gentoo-59495a0e02d1bd46491b72f6c707d7fca5011863.tar.bz2
gentoo-59495a0e02d1bd46491b72f6c707d7fca5011863.zip
dev-python/python-docs: Bump to 3.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.11.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index 1b704ee2d4a3..57ae66409900 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.9-docs-html.tar.bz2 7379489 BLAKE2B ab7bc918417682179d60d80685d2e22a4c8eb5f1080fc8a0469f525192426a72adaec7fba0c3c654b6ea3892b4723d2a1cc7b827c17648e7710c569bfc591d30 SHA512 06677a0c5d841833e590979cc174dc4dc7d7b67c277e5af680afc205d913e11987985e1a17d8f90538ca96fae4a9940c922c7f538dea222b7ffcd446a7168b4e
DIST python-3.11.1-docs-html.tar.bz2 7701638 BLAKE2B 9c5452c2b8601dc5f9b681ebe8e5bbf6a74f915310554c158997bed0fdf471354c6de0eb260b31717cb9310f0d96b3a5ff497173cd17e2b278372e6af12f9ad5 SHA512 2541b13c2b7b06aa4d8750a4399f761619600d8978e691f0910365329167565d8a306d45895e3fb6c83e6b32b8e84943b0056fcd6264539500bac7a5625856ba
+DIST python-3.11.2-docs-html.tar.bz2 7779519 BLAKE2B d9e1faa1414b18923c08686097d4d65613768c404f712a8ca104f546938016afe5e47bdec25296db1792f1ec49a11ed9899b062b9fdb24e93b2f60d6f49ae82c SHA512 0a6b54b0e3579f640a78e9255ff60b6b18f36752b8949f0f19e5c2fb84c33775c761bed907fb45dc606e5bc894068086cac4935574e89421bee55e8b2127d7d8
DIST python-3.8.16-docs-html.tar.bz2 6697934 BLAKE2B 99fb1b8e95c3719b1146e845051fa6b9fbf61fabfdd1fe6d93a44e6a46f4b4e44c9ce0adef89cfdeafc8b67d290adda21d295f492a8f54c069ad86fba4952c0b SHA512 aaffc1f4d56be0ff7fbd35c7ca690d9089f9686d957669852aff1406efad2bee52b2b965ffd652780da6048ff9d89e6bbc421e92588841b89d73af43ad4970fb
DIST python-3.9.16-docs-html.tar.bz2 6965048 BLAKE2B 14d30cf5c444b993409751d17959bc46668d2b6e5be76e10d36adb0b8704a2a3908d829e8aa12d384efab31f8b60b462f711f2fa6adf8bc84fbdfe25e4cbc703 SHA512 38828ca880e3ed84a705dba465430f1b9623fec830662805008847c5d44ce04225ea7c2173d3eb138fd98e134fa2bb9ed84788e2b1d045bf9cf20e78e12d4472
diff --git a/dev-python/python-docs/python-docs-3.11.2.ebuild b/dev-python/python-docs/python-docs-3.11.2.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.11.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}