summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-05-10 17:19:26 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-05-18 18:14:01 +0300
commit5f15365414462cce163d8a5aa63e2d5aafc63c4b (patch)
tree6cf88f9ebfe5f64dda463ca89792e9e1786e65b0 /dev-python/python-gammu
parentapp-mobilephone/gammu: bump to 1.42.0 (diff)
downloadgentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.tar.gz
gentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.tar.bz2
gentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.zip
dev-python/python-gammu: bump to 3.2.4
just bump Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/25424 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python-gammu')
-rw-r--r--dev-python/python-gammu/Manifest1
-rw-r--r--dev-python/python-gammu/python-gammu-3.2.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-gammu/Manifest b/dev-python/python-gammu/Manifest
index fede82ec0d79..45683f07729a 100644
--- a/dev-python/python-gammu/Manifest
+++ b/dev-python/python-gammu/Manifest
@@ -1 +1,2 @@
DIST python-gammu-2.11.tar.gz 135567 BLAKE2B 133172cfd0715ff6b5bd47b93e5d93d52af3e608459ba1158bf008da9b5f24f6d155c04334dea7ff2cacdea678f00d986838a139290d5f8ac874bb9702fcd5e6 SHA512 cdf3a54fc538fecdbe3dae63f0534094ce94a289998f9b670a0b3e12a3c571eb46ee86eae67a7a8d2428698850046d5c75569753bf77551cd395d315e6f9b70d
+DIST python-gammu-3.2.4.tar.gz 144136 BLAKE2B ef06b78568e9b88da95d09029191a2de0c4e26cb6b222326bffd0134a9c7eb743bab20201347d3be8a81db43f6005ec2a0550e1976a59de9ee9202c733ae41e0 SHA512 9d76b402c50018cc52476376952edebb6b0934aa374ea2a2177f5497d0949fcc77644aa2a35c7402b3f2179962d903409b7b1949c5e85a0e5130058d34f89664
diff --git a/dev-python/python-gammu/python-gammu-3.2.4.ebuild b/dev-python/python-gammu/python-gammu-3.2.4.ebuild
new file mode 100644
index 000000000000..bcad3a30d78f
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-3.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+SRC_URI="https://github.com/gammu/python-gammu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-mobilephone/gammu-1.34.0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x /usr/share/doc/${P}/examples
+ dodoc -r examples
+ fi
+}