summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 06:11:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 07:11:09 +0100
commit34c8e9330a6cf4ff9c9264f08e6f5e7155d0c781 (patch)
tree1fe932ceb4dca39e44f31058e8144a98a716845f /dev-python/python-socks
parentdev-python/pyzmq: Bump to 25.0.1 (diff)
downloadgentoo-34c8e9330a6cf4ff9c9264f08e6f5e7155d0c781.tar.gz
gentoo-34c8e9330a6cf4ff9c9264f08e6f5e7155d0c781.tar.bz2
gentoo-34c8e9330a6cf4ff9c9264f08e6f5e7155d0c781.zip
dev-python/python-socks: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index b40774a02960..608424571f34 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,4 @@
DIST python-socks-2.0.3.gh.tar.gz 40697 BLAKE2B c1e6f72763d1bd767af78ea1188e411814a6d41f703488dd67165d5a9b9ce1e2f9070b35a46cd72859b65c10519cdb02c91d1702a97c2d82cb5891b46187d02a SHA512 9d51e61d03b4a46e94a66fc037ac759715db2e2c5d631aaf6088a0363ad13140c00da44a513088a40c0f149b9d4ee2bb4165f59f76c3956f0aede8104772fc5d
DIST python-socks-2.1.0.gh.tar.gz 31251 BLAKE2B b32b35c746066c10fa1e52677e42058e6196eb1c19cfc120a670e86daf8f920a4d6be3d1d92f984b68d635496da992b33f196277a1b22b254fe045988a15d2f1 SHA512 66da2da1d8103570e44d0a2ace03c24695b7319c562d7f96242c713b9d03ea693a2ece3cf6869cea686c330a9fb05aa35a443bad5a638d843b4fc7b24a8e6a82
DIST python-socks-2.1.1.gh.tar.gz 31306 BLAKE2B f42f88089b0438722b076bcbbbe194b6ed621dec34f850861d791418ff453e6f97aa4e2f2ccf69024c5c562f7d1c8e1110e9930360252556bc77dd44b9a20fc0 SHA512 d68c5d0b0975283a8a86f701db5a8037beb9368edef591876abba2524593114fdcc933fa3dc5eca8123afcc6fc0eb3eacfbbf40e54acb87e973fc7b49ed3c8dc
+DIST python-socks-2.2.0.gh.tar.gz 32483 BLAKE2B 44dba93f29b3466515591bced694b1f17a76d7a9410829f8d4cfe0c4da18b00dddb9a84b37a9ce74dd20517a3567c06f4b96e4cc4724e88244dd11b097b3da9e SHA512 7189a249fcbc80c13f6070cd82d785ca4be48cbaf0a0e37da486b8517f551b9a22678a0c4d65f98adb30c719b5f47a3e9cd0133633a429283b04cdae089ed6a6
diff --git a/dev-python/python-socks/python-socks-2.2.0.ebuild b/dev-python/python-socks/python-socks-2.2.0.ebuild
new file mode 100644
index 000000000000..255c91fccda5
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest