summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-26 07:57:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-26 08:01:32 +0100
commit2f4ccb4ff19ac6054a538a1d3186e07833cea1f0 (patch)
tree568277a1a6422e221b1195020806cc762a51728c /dev-python/python-utils
parentdev-python/pipdeptree: Bump to 2.24.0 (diff)
downloadgentoo-2f4ccb4ff19ac6054a538a1d3186e07833cea1f0.tar.gz
gentoo-2f4ccb4ff19ac6054a538a1d3186e07833cea1f0.tar.bz2
gentoo-2f4ccb4ff19ac6054a538a1d3186e07833cea1f0.zip
dev-python/python-utils: Bump to 3.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.9.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 9785aa7d699e..2b664aaeec91 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python_utils-3.9.0.tar.gz 35352 BLAKE2B 8d247d28a1ed797d1058f6bf45469230f5fcf3f8d305e195a49229deef5d41552e07b5c2e7543223f2df608feffa6df2f57828863acc437ff9c3c2a11e797703 SHA512 fe6313b18f53a56d71a9ca9b40f7bfe61629f7c5cf0b9088adf81ed8aa78b1c5a593c59ec178ec6c87424ae0730c9cb15d6eaa1a129d871f75b67d1d4f6938bf
+DIST python_utils-3.9.1.tar.gz 35403 BLAKE2B 8cad7a9dbbc1a2d537d1fe7342846f1b1da15d41934cef861fcc0ad8da68d67fbab8f33ab6b579ff0f67d8c8dada6411a8087b46f9682990e7c2410802009c05 SHA512 f458446edde989ad338d20b11b2486148848c9373ef627938ccff99ab186517594428d7ec068d0d110a04c8ceee665735d33c662592b96920b8faf8aeb065239
diff --git a/dev-python/python-utils/python-utils-3.9.1.ebuild b/dev-python/python-utils/python-utils-3.9.1.ebuild
new file mode 100644
index 000000000000..aa5d56d259e4
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.9.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+EPYTEST_DESELECT=(
+ # fragile
+ _python_utils_tests/test_time.py::test_timeout_generator
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}