summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-07 05:58:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-07 06:43:01 +0200
commitd6e3c4ef84fc7baa28258975426607a44497bfd9 (patch)
tree2548803133026a33421c8ce6e8cf028378a9aa86 /dev-python/pywayland/pywayland-0.4.17.ebuild
parentdev-python/sqlglot: Bump to 18.11.6 (diff)
downloadgentoo-d6e3c4ef84fc7baa28258975426607a44497bfd9.tar.gz
gentoo-d6e3c4ef84fc7baa28258975426607a44497bfd9.tar.bz2
gentoo-d6e3c4ef84fc7baa28258975426607a44497bfd9.zip
dev-python/pywayland: Bump to 0.4.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywayland/pywayland-0.4.17.ebuild')
-rw-r--r--dev-python/pywayland/pywayland-0.4.17.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pywayland/pywayland-0.4.17.ebuild b/dev-python/pywayland/pywayland-0.4.17.ebuild
new file mode 100644
index 000000000000..3741622e025e
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -rf pywayland || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}