summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pywebkitgtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pywebkitgtk')
-rw-r--r--dev-python/pywebkitgtk/Manifest1
-rw-r--r--dev-python/pywebkitgtk/metadata.xml17
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild51
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pywebkitgtk/Manifest b/dev-python/pywebkitgtk/Manifest
new file mode 100644
index 000000000000..dc357fdde8ed
--- /dev/null
+++ b/dev-python/pywebkitgtk/Manifest
@@ -0,0 +1 @@
+DIST pywebkitgtk-1.1.8.tar.gz 342370 SHA256 7092212933000f23b3042135f01a371bd6a8f980c6b8d8b9dc7e20a1101d699c SHA512 18de613188f68d97be306af877b5d071758da1d08dfe4d4fa6ec275e931d9513520541747dcdcddacf5edf7e21061956ae2f3842155904c2e77c9a758e98e77f WHIRLPOOL e9bf3d71692682c65006a643fa1055ad06334a777d5e4c417ca8193b4e29d646522cfb67d9706e0ba1d93ecefe7d4734dd5e22456a9094ffbb01cf24b182e223
diff --git a/dev-python/pywebkitgtk/metadata.xml b/dev-python/pywebkitgtk/metadata.xml
new file mode 100644
index 000000000000..ee6dda9ab4b3
--- /dev/null
+++ b/dev-python/pywebkitgtk/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>srinclan@gmail.com</email>
+ <name>Sergio Rodriguez</name>
+ </maintainer>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pywebkitgtk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..6769cad75314
--- /dev/null
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-r1 virtualx
+
+DESCRIPTION="Python bindings for the WebKit GTK+ port"
+HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
+SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="test"
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-libs/libxslt
+ >=net-libs/webkit-gtk-1.1.15:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=( --disable-static )
+ python_parallel_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_test() {
+ testing() {
+ local test st=0
+ for test in tests/test_*.py; do
+ PYTHONPATH="${BUILD_DIR}/.libs" "${PYTHON}" "${test}"
+ (( st |= $? ))
+ done
+ return ${st}
+ }
+ VIRTUALX_COMMAND=testing python_foreach_impl virtualmake
+}
+
+src_install() {
+ local AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+ local DOCS=( AUTHORS MAINTAINERS NEWS README )
+ python_foreach_impl autotools-utils_src_install
+}