summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-25 03:45:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-25 04:02:32 +0200
commitdc0b76b6fdd708e90fa5d6e50c55fa748a35d201 (patch)
tree329c113c25685d4e39f3b429a29b2b848d555ced /dev-python/pyzotero
parentdev-python/alembic: Bump to 1.10.4 (diff)
downloadgentoo-dc0b76b6fdd708e90fa5d6e50c55fa748a35d201.tar.gz
gentoo-dc0b76b6fdd708e90fa5d6e50c55fa748a35d201.tar.bz2
gentoo-dc0b76b6fdd708e90fa5d6e50c55fa748a35d201.zip
dev-python/pyzotero: Bump to 1.5.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzotero')
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index 76796cf8e752..b352eec87f4a 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
DIST pyzotero-1.5.5.tar.gz 525725 BLAKE2B ec1c200811697b5830f757e527ad3f21abea62c680e32b2132d616b4e07c919a3e692a98cb726f43b9c456a23c375f962847fbd61a466f476545d491b7ed0576 SHA512 88db72c834e084f025eafb6c85d1e7cb4c4f6f73eb518bfe4ac008f51fc752fc7e74be2c0e48a0e8a9bc2acefb78a48ff907ee2e0e26c58f25e853f923848fea
+DIST pyzotero-1.5.9.tar.gz 526093 BLAKE2B bf29b557226363d71d536c41fb168b55b0d63dace5789f8abc92b8342bffb1ddcb4344132a68cc401db0ca0a536f534141690b017bc4dcf4d45299dec308a554 SHA512 be8c2135d3cc1bc5defc27a4eaf5233ced01a7c84cdf89074ce318558728c9356ddcf9e4ede4012b03c1f836dde641fee9366ca954e5d3cf35642638c3e38145
diff --git a/dev-python/pyzotero/pyzotero-1.5.9.ebuild b/dev-python/pyzotero/pyzotero-1.5.9.ebuild
new file mode 100644
index 000000000000..9d9ad538c0fd
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest