summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-30 12:44:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-30 12:44:01 +0100
commite56fe425a7fab03d587dfcf985f05ac70d3de7fb (patch)
tree5e4ad32828279560e9dd35e2563f750ab5813c41 /dev-python/quart
parentdev-python/flask: Remove old (diff)
downloadgentoo-e56fe425a7fab03d587dfcf985f05ac70d3de7fb.tar.gz
gentoo-e56fe425a7fab03d587dfcf985f05ac70d3de7fb.tar.bz2
gentoo-e56fe425a7fab03d587dfcf985f05ac70d3de7fb.zip
dev-python/quart: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quart')
-rw-r--r--dev-python/quart/Manifest1
-rw-r--r--dev-python/quart/quart-0.19.8.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/quart/Manifest b/dev-python/quart/Manifest
index 64f38698a549..c53e5350e070 100644
--- a/dev-python/quart/Manifest
+++ b/dev-python/quart/Manifest
@@ -1,2 +1 @@
-DIST quart-0.19.8.gh.tar.gz 747979 BLAKE2B 434c5493f01a1ea0cdd223145f52327229af0fd4ddf5739628847c4f78f1b8d76dcb827370446a50227b1afa96d829a47304efed3d017b405632c15c01034292 SHA512 658384387f064f3d0d9af3f79588ab88d28ed7a0922417cf809d2c0ce2e5d4de3c11649368ed57ba3739f88ac2fb8753be31a2e740d052773129a421a38e2115
DIST quart-0.19.9.gh.tar.gz 747986 BLAKE2B cd6c9d919e6174305490b59b76815d0b0fcd854c0527c517a463563ed1b3b5dc0fd7ac7e7baf555a56b277cf1a64c6e54da5d9ddb368e862736897dfb34a6cc0 SHA512 7a3020a9fb9c49cdf1ba91ec3ea6a6bb07da5a0571badefc880864921c4b7d1219250bb896cc614dd525920380d660204063431abd99bf0d99418dd3206c0eae
diff --git a/dev-python/quart/quart-0.19.8.ebuild b/dev-python/quart/quart-0.19.8.ebuild
deleted file mode 100644
index 8ee917f1f2d3..000000000000
--- a/dev-python/quart/quart-0.19.8.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python ASGI web microframework with the same API as Flask"
-HOMEPAGE="
- https://github.com/pallets/quart/
- https://pypi.org/project/Quart/
-"
-# no tests in sdist as of 0.19.4
-SRC_URI="
- https://github.com/pallets/quart/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/aiofiles[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.6[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/hypercorn-0.11.2[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/jinja2[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p asyncio
-}