summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:20:27 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:17:47 +0100
commitf18a1453eb18abf002ff76ce948b013c7a94c191 (patch)
treedd83ccd8cbfabb9aace184c3b91c3fb044d3be93 /dev-python/rospkg
parentdev-python/urdf_parser_py: treeclean (diff)
downloadgentoo-f18a1453eb18abf002ff76ce948b013c7a94c191.tar.gz
gentoo-f18a1453eb18abf002ff76ce948b013c7a94c191.tar.bz2
gentoo-f18a1453eb18abf002ff76ce948b013c7a94c191.zip
dev-python/rospkg: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/files/gentoo.patch15
-rw-r--r--dev-python/rospkg/metadata.xml11
-rw-r--r--dev-python/rospkg/rospkg-1.4.0.ebuild41
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild41
5 files changed, 0 insertions, 109 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
deleted file mode 100644
index fb28f34d948c..000000000000
--- a/dev-python/rospkg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rospkg-1.4.0.tar.gz 91707 BLAKE2B 02ee199a5f59d1256561cda0e9a6f05e40337a604bfba34d076cd09812fb4cd2f253785e894e9590de86226e8e250d77f50f18c4ffb2857c69095f329c7aa58e SHA512 4e4a40961ed1cfba0746069725378414dc61d3f55e479e7af5efa211419e34e44f5964f8ab41a8c4c9e9b74ae275fd29cf6ffda0eab66b6a0ec7fc7066719797
diff --git a/dev-python/rospkg/files/gentoo.patch b/dev-python/rospkg/files/gentoo.patch
deleted file mode 100644
index 5a9e7738b390..000000000000
--- a/dev-python/rospkg/files/gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Strip ros_packages/ from paths. ros_packages is only for avoiding to crawl the
-whole /usr but the real one in the path without it.
-
-Index: rospkg-1.1.0/src/rospkg/rospack.py
-===================================================================
---- rospkg-1.1.0.orig/src/rospkg/rospack.py
-+++ rospkg-1.1.0/src/rospkg/rospack.py
-@@ -59,6 +59,7 @@ def list_by_path(manifest_name, path, ca
- path = os.path.abspath(path)
- basename = os.path.basename
- for d, dirs, files in os.walk(path, topdown=True, followlinks=True):
-+ d = d.replace('ros_packages/', '')
- if 'CATKIN_IGNORE' in files:
- del dirs[:]
- continue # leaf
diff --git a/dev-python/rospkg/metadata.xml b/dev-python/rospkg/metadata.xml
deleted file mode 100644
index c01ba35d0853..000000000000
--- a/dev-python/rospkg/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros-infrastructure/rospkg</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/rospkg/rospkg-1.4.0.ebuild b/dev-python/rospkg/rospkg-1.4.0.ebuild
deleted file mode 100644
index 4e4d4e300823..000000000000
--- a/dev-python/rospkg/rospkg-1.4.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="Standalone Python library for the ROS package system"
-HOMEPAGE="https://wiki.ros.org/rospkg"
-
-if [[ ${PV} = *9999 ]]; then
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
- inherit git-r3
-
- S="${WORKDIR}/${PN}"
- EGIT_CHECKOUT_DIR="${S}"
-else
- SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-PATCHES=(
- "${FILESDIR}/gentoo.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
deleted file mode 100644
index 4e4d4e300823..000000000000
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="Standalone Python library for the ROS package system"
-HOMEPAGE="https://wiki.ros.org/rospkg"
-
-if [[ ${PV} = *9999 ]]; then
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
- inherit git-r3
-
- S="${WORKDIR}/${PN}"
- EGIT_CHECKOUT_DIR="${S}"
-else
- SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-PATCHES=(
- "${FILESDIR}/gentoo.patch"
-)
-
-distutils_enable_tests pytest