summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-22 17:09:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-22 17:28:56 +0200
commit90e48423f7c0e5a1117b1790606e077f005596ec (patch)
treeffac02caeda02ea2e525a081cab474d2a3f4517a /dev-python/rst-linker
parentdev-libs/boost: add 1.85.0 (diff)
downloadgentoo-90e48423f7c0e5a1117b1790606e077f005596ec.tar.gz
gentoo-90e48423f7c0e5a1117b1790606e077f005596ec.tar.bz2
gentoo-90e48423f7c0e5a1117b1790606e077f005596ec.zip
dev-python/rst-linker: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-2.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 0aec84dfc54e..3dbe53e3f09f 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1 +1,2 @@
DIST rst.linker-2.4.0.tar.gz 11340 BLAKE2B a1ae9c811b7d6fa2821bfbf5787dce75fd3d7e5d933ec15fbac9cd3bde08cfad59fdc81b3b58dc39d1209a27ca9dd8d2ecd68034b434b3f6d15469bfb98efa3d SHA512 31e3427ecf35b433cc9650138ee36090e99003b72c69b60b530835eb624d7eb13aae4cf81cc0044b36750798a4b8aa676e53e3b9eb335430076593640a243940
+DIST rst_linker-2.5.0.tar.gz 11548 BLAKE2B eafa6a0076dd51d05779710cb3b41f4b6e5109b25ea71537bc4f4e75d8c0fe4c9329321833e5a9253bb4a51fab706488a78ece4679a4c52cd7fc0295cc29e76f SHA512 7aaa55ccbe34767f8c0e085703872f4112c5db142e81f7024fd0653fa74fcf0b9d15fec06998268e8161dc70dac6935ba7b380992a132ecaa2548ed0db3b5a13
diff --git a/dev-python/rst-linker/rst-linker-2.5.0.ebuild b/dev-python/rst-linker/rst-linker-2.5.0.ebuild
new file mode 100644
index 000000000000..38460daa5311
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="
+ https://github.com/jaraco/rst.linker/
+ https://pypi.org/project/rst.linker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest