summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rtf2xml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rtf2xml')
-rw-r--r--dev-python/rtf2xml/Manifest1
-rw-r--r--dev-python/rtf2xml/metadata.xml10
-rw-r--r--dev-python/rtf2xml/rtf2xml-1.33-r1.ebuild25
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rtf2xml/Manifest b/dev-python/rtf2xml/Manifest
new file mode 100644
index 000000000000..5fdcbc0de056
--- /dev/null
+++ b/dev-python/rtf2xml/Manifest
@@ -0,0 +1 @@
+DIST rtf2xml-1.33.tar.gz 421817 SHA256 8dbfd3b8f266568775c2de812620288543771135212a836d1dd43d5dd45575a0 SHA512 ffca0f091319432e7d3f3b94fe8946a4665b026fe91ad90f3b9fa8671e3d7c31b71739df3655e368c44c26ad3b5d0e6a5b80ebd58856fb135253337b6b703031 WHIRLPOOL ebb8f284b0f257b2de2ef89b25e3f6cda320f398a98e47a0ed0a5740537351dbf5cbc4af7a5d4208d5da3c5fbf7c3c0c1ace4e60719e379210d85830532ee04b
diff --git a/dev-python/rtf2xml/metadata.xml b/dev-python/rtf2xml/metadata.xml
new file mode 100644
index 000000000000..9e010f32aff7
--- /dev/null
+++ b/dev-python/rtf2xml/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rtf2xml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rtf2xml/rtf2xml-1.33-r1.ebuild b/dev-python/rtf2xml/rtf2xml-1.33-r1.ebuild
new file mode 100644
index 000000000000..cc42f6d5bfe7
--- /dev/null
+++ b/dev-python/rtf2xml/rtf2xml-1.33-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Microsoft RTF file to structured XML"
+HOMEPAGE="http://rtf2xml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/html/. )
+ distutils-r1_python_install_all
+}