summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-13 05:09:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-13 06:28:39 +0100
commit5706bba0283d64e43ab48ca1a172291d9fd511be (patch)
tree36a17fa1e548c361ab642687ea8cf1ed3905b4e4 /dev-python/simpy/simpy-4.1.1.ebuild
parentwww-client/chromium: Stabilize 119.0.6045.105 arm64, #917208 (diff)
downloadgentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.tar.gz
gentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.tar.bz2
gentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.zip
dev-python/simpy: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simpy/simpy-4.1.1.ebuild')
-rw-r--r--dev-python/simpy/simpy-4.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/simpy/simpy-4.1.1.ebuild b/dev-python/simpy/simpy-4.1.1.ebuild
new file mode 100644
index 000000000000..e7d76b0c98c1
--- /dev/null
+++ b/dev-python/simpy/simpy-4.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="
+ https://simpy.readthedocs.io/
+ https://gitlab.com/team-simpy/simpy/
+ https://pypi.org/project/simpy/
+"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}