summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-12 18:59:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-12 19:34:01 +0200
commit98933207c03013f2df7ca11d623e1bc123783cfd (patch)
treebf8b4bf9b2c984bd21ae2f45392c88dadc459448 /dev-python/sphinx-autodoc-typehints
parentdev-python/nbclient: Bump to 0.6.0 (diff)
downloadgentoo-98933207c03013f2df7ca11d623e1bc123783cfd.tar.gz
gentoo-98933207c03013f2df7ca11d623e1bc123783cfd.tar.bz2
gentoo-98933207c03013f2df7ca11d623e1bc123783cfd.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 968d9023abd6..c75288fd577e 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.17.0.gh.tar.gz 26087 BLAKE2B d2193378160404dd18ee066dd09c299f69d92b3b747edcd88910a8eb29a707b0ad3f7c95e56a0137c19010d37bddd3d72c5d378dcf72376ea36d69ab2eba52d4 SHA512 0b35cbc3a26cd084c7c741df1ad0a0887eca9943adc16980f7dbc3304c00854bb2861b1314c126e59b2d59cdbff22f5f466cc433e485ec05e40ed93e36ee9650
+DIST sphinx-autodoc-typehints-1.18.0.gh.tar.gz 26201 BLAKE2B 00c2be7d1a9770bf3c2a133ae5f810703e70afc0ce3372c5e667ef9e8783ce74c28fd796211a8bb38507ed1d1142c52461c6d6002069756961dc8d95e837337b SHA512 fa2202551365e929b5dda4c97f9565fec124cb1edda3a957953f4d59716d1c1e28adca769c3dbeadf265763cfb123bf6fefce0f9d9467daf4043f93d360195e3
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.0.ebuild
new file mode 100644
index 000000000000..566a798017bd
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.18.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-python/sphinx-4.5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2[${PYTHON_USEDEP}]
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}