summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-08 15:45:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-08 17:54:53 +0100
commitb588b4b55054abad5df51ac9ba628a2d28c24199 (patch)
tree13bb21776bf77d92e6a68bd4da32c12a1eee66f8 /dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild
parentdev-python/cbor2: Bump to 5.4.6 (diff)
downloadgentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.tar.gz
gentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.tar.bz2
gentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.zip
dev-python/sphinx_ansible_theme: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild')
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild
new file mode 100644
index 000000000000..91f35e9574e9
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="
+ https://github.com/ansible-community/sphinx_ansible_theme/
+ https://pypi.org/project/sphinx-ansible-theme/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/ansible-pygments' \
+ 'dev-python/sphinx-notfound-page'