summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-06 06:17:45 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-06 06:18:05 -0400
commite2c9cdbe87873916caf2e2b55e220c7e8c362ada (patch)
tree6135cb2bf8d009904ee2b2c59361c7b9a41715b7 /dev-python/sshtunnel
parentsys-apps/ibm-powerpc-utils: Add live ebuild (diff)
downloadgentoo-e2c9cdbe87873916caf2e2b55e220c7e8c362ada.tar.gz
gentoo-e2c9cdbe87873916caf2e2b55e220c7e8c362ada.tar.bz2
gentoo-e2c9cdbe87873916caf2e2b55e220c7e8c362ada.zip
dev-python/sshtunnel: Bump EAPI, drop tests
Tests are now failing consuming all resources until OOM killed. Drop tests until upstream figures it out. Bug: https://bugs.gentoo.org/683774 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild
new file mode 100644
index 000000000000..a4575517e241
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://bugs.gentoo.org/683774
+RESTRICT="test"