summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-13 08:16:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-13 09:18:50 +0200
commita7480cf49fcb3ff6ad789fafe114224bf19b1e2c (patch)
treeb0929ba3178e96911a71990697c50b4a1fce9672 /dev-python/tblib
parentdev-python/dj-search-url: Use PEP517 build (diff)
downloadgentoo-a7480cf49fcb3ff6ad789fafe114224bf19b1e2c.tar.gz
gentoo-a7480cf49fcb3ff6ad789fafe114224bf19b1e2c.tar.bz2
gentoo-a7480cf49fcb3ff6ad789fafe114224bf19b1e2c.zip
dev-python/tblib: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tblib')
-rw-r--r--dev-python/tblib/tblib-1.7.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tblib/tblib-1.7.0-r1.ebuild b/dev-python/tblib/tblib-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..a1a281d2eb4d
--- /dev/null
+++ b/dev-python/tblib/tblib-1.7.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Traceback fiddling library for Python"
+HOMEPAGE="
+ https://github.com/ionelmc/python-tblib/
+ https://pypi.org/project/tblib/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}