summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-27 11:07:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-27 12:17:19 +0200
commit35a997d925276b782c656d5d59d40377078acfc7 (patch)
tree0e7e98e1565dbfd100da5e602f91e13b1a1b7b03 /dev-python/tempora/tempora-1.6.1.ebuild
parentnet-p2p/airdcpp-webclient: remove old. (diff)
downloadgentoo-35a997d925276b782c656d5d59d40377078acfc7.tar.gz
gentoo-35a997d925276b782c656d5d59d40377078acfc7.tar.bz2
gentoo-35a997d925276b782c656d5d59d40377078acfc7.zip
dev-python/tempora: bump to 1.6.1, add doc.
Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2419 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/tempora/tempora-1.6.1.ebuild')
-rw-r--r--dev-python/tempora/tempora-1.6.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tempora/tempora-1.6.1.ebuild b/dev-python/tempora/tempora-1.6.1.ebuild
new file mode 100644
index 000000000000..b602e5964b91
--- /dev/null
+++ b/dev-python/tempora/tempora-1.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# The calc-prorate binary used to be part of jaraco.utils
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !<=dev-python/jaraco-utils-10.0.2
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}