summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-13 22:00:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-13 22:00:25 +0300
commit4fd0dbc813f9b237607373b8b20ba52f1b1395b8 (patch)
tree4ff0775314446fb790e2e362e9da58f713ba0f72 /dev-python/tifffile
parentdev-python/APScheduler: add 3.10.2 (diff)
downloadgentoo-4fd0dbc813f9b237607373b8b20ba52f1b1395b8.tar.gz
gentoo-4fd0dbc813f9b237607373b8b20ba52f1b1395b8.tar.bz2
gentoo-4fd0dbc813f9b237607373b8b20ba52f1b1395b8.zip
dev-python/tifffile: add 2023.8.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2023.8.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index f900cc59cff0..a2530f6d041c 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2023.7.18.gh.tar.gz 336236 BLAKE2B ac4fef74c21aa2c32a21b5e34a716a4a859f41f33d07ced607a8634ca469bf09c264a4d3d170b82596bb61968ca4f480c1abf9d2a4584f2a2de44f44ea1c0acf SHA512 3c3f03b921723da91e07b153f69961c321fa6d3ba2006cd21debba16c4bd0041de457d2df0d6e1b30d089260a2620d7bd27b53fbcf9d88e675d271883b6a60b5
+DIST tifffile-2023.8.12.gh.tar.gz 336657 BLAKE2B 8dfc2403cfa451209f8892326012273b23584c1e50f4172fe7770b850bb591013ef89bdc249976ba0946b4a7065dc603c5817d3f9f201e837b32d8471c4acf16 SHA512 2c14bb5b6ab89f2973ef10b511a2d12568312e1963c227e2ea152197c4e27610eb7e4fc533d47932c45d1fc32bb0aa25d09d0608cd752fd7be8b8ec26ed13eef
diff --git a/dev-python/tifffile/tifffile-2023.8.12.ebuild b/dev-python/tifffile/tifffile-2023.8.12.ebuild
new file mode 100644
index 000000000000..5b8f82b2f720
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2023.8.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+ # missing private marker
+ # https://github.com/cgohlke/tifffile/pull/195
+ tests/test_tifffile.py::test_issue_invalid_predictor
+)