summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-19 18:40:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-19 18:40:21 +0300
commitc28f44832ed8615b3de7966a3e794a7c5a2d60a9 (patch)
tree4a2572f1638c78e69f037af488e1740e37758fbd /dev-python/time-machine
parentdev-python/apipkg: add 3.0.2 (diff)
downloadgentoo-c28f44832ed8615b3de7966a3e794a7c5a2d60a9.tar.gz
gentoo-c28f44832ed8615b3de7966a3e794a7c5a2d60a9.tar.bz2
gentoo-c28f44832ed8615b3de7966a3e794a7c5a2d60a9.zip
dev-python/time-machine: add 2.13.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/Manifest1
-rw-r--r--dev-python/time-machine/time-machine-2.13.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
index 8cae66584abc..fd9ed7540f39 100644
--- a/dev-python/time-machine/Manifest
+++ b/dev-python/time-machine/Manifest
@@ -1,2 +1,3 @@
DIST time-machine-2.11.0.gh.tar.gz 28075 BLAKE2B 2eb07ac60d4014e5796fefcf5cb846d60fef1887fe01459d906a2118eddc924d60642131530f76e131080e2989f60263bda2fbcc0cc917e0f9452d16a4f640a6 SHA512 5bd5d76e2ecc392c249e86e2cfe54ee94a99a4e1cd1dd7e00b240e1299426d87a284ec270ae36aeb82acfe06d974d5aeca27ae977a480441e4daa5b852d00198
DIST time-machine-2.12.0.gh.tar.gz 27743 BLAKE2B 4ed0c9901edb9c698b8bbba6df80d12b06f344ad6ee8f9e89577264da1f0211774c2d227d02dc1ab0ceb5b905094168d19cdebc00a91a955d216729082ecbc28 SHA512 4708cdc3aa0ec06907d0ee1219ceb074947fc962ab6f0d3606e5273f3d64ca278bb43254d924c04364b967301cf69229ced70d7b1db92b0b6dff1523cccb2f82
+DIST time-machine-2.13.0.gh.tar.gz 28747 BLAKE2B 88836d2b9ad34c8d256b576ab6b2bfe263232fb50d2e95f13049f84dbc838283811ebc54c5bb68493ef966e64777983ab6bcb7fafccda6dc74e00d3bb6a2108f SHA512 26a852d93633e037585ec8fcd563c86af8d977a87633dbeb66cf23c9ca49ca0ae536bdcdcdf809ee2ab423c197610c630d506bc3bf4f13c373d806cee2d8c598
diff --git a/dev-python/time-machine/time-machine-2.13.0.ebuild b/dev-python/time-machine/time-machine-2.13.0.ebuild
new file mode 100644
index 000000000000..d6f96f71fc73
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest