summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-16 06:50:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-16 07:09:33 +0100
commit32af88f8355e1bcdfae294fa2b5af6ae00e0615a (patch)
treeec4299dd422565d67d97935fa746f888cb399c30 /dev-python/tox
parentmedia-libs/libharu: keyword 2.4.2-r1 for ~riscv (diff)
downloadgentoo-32af88f8355e1bcdfae294fa2b5af6ae00e0615a.tar.gz
gentoo-32af88f8355e1bcdfae294fa2b5af6ae00e0615a.tar.bz2
gentoo-32af88f8355e1bcdfae294fa2b5af6ae00e0615a.zip
dev-python/tox: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.3.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index f108a883deda..096e8029774b 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -3,3 +3,4 @@ DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3
DIST tox-4.2.6.gh.tar.gz 290939 BLAKE2B ea505ef8a852c17dbae1489b91939f38d8a7bfca45a73cb259f2206928dc88294933ad4e420d148379e429f1dc2924e41028e6d5624aea4dcf170473344583ce SHA512 21efd8418a96f1570e33d4e903e4233eedb4ac6592b9df44dfe686414b00bb4fb1fb9bfe948e301e708e31adae609ecc37e9485d4b2d3b879de66da071c90e51
DIST tox-4.2.7.gh.tar.gz 291533 BLAKE2B 0ed8deb01b3859dbcf37c6a0ed255254994060f195e7d58eefabcaa85b69dd60bd35391c962b2a5476b305787d409d01c9ce71125da418d12f2b3b08604b557e SHA512 2049e797d97b5202969d1d9812d92987ae3f6d47ce1fe09432fefc0912bdd8141abcf63acbd654b899fcfae9282a60f0950c445b224494b6c03f5631dcdb9d41
DIST tox-4.2.8.gh.tar.gz 291662 BLAKE2B 5a92bb3fd0659717b020a77658b2337e8ab153242136a0a6a700fea63e142cd263cda8ee58d9b78b98e9ba4cb1138573bacc48d7cf488123eff743528e1a4b6d SHA512 1a332dacc2096dcee021182db1014ff9a0b7f32a573d3ab508eed94a4f60773919c6350e1cab3ea0df79bd2274bb76da422e2d75e99853a67c276db02ba3232e
+DIST tox-4.3.0.gh.tar.gz 296472 BLAKE2B 695efd31fef5f9aeb1bce71d95e913c38b9cb0dce0bcd955d85b492142088b89b59ab2a09754189959488042c1dfc6e476b17ebcb72a1b6ce2e9add8b764d6d0 SHA512 4ec09f4b43d7be8784af7821d1fbb2c7c705b84386b2496dffcbaf9f2943d1e5f00743f214e26839ce64635b9091b43b5747c51f4aaebc0ac27b08f8d5b31921
diff --git a/dev-python/tox/tox-4.3.0.ebuild b/dev-python/tox/tox-4.3.0.ebuild
new file mode 100644
index 000000000000..287d0a04be39
--- /dev/null
+++ b/dev-python/tox/tox-4.3.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv"
+
+RDEPEND="
+ >=dev-python/cachetools-5.2.1[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.8.2[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ # the minimal bounds in tox are entirely meaningless and new packaging
+ # breaks setuptools
+ sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+
+ epytest
+}