summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-18 09:55:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-18 10:17:48 +0100
commit5ce9807c146a92d4a4ea2a266dec32b09a91ec6c (patch)
treeb19129cfadd36e20b21846f4fa121adf4b9dd5ba /dev-python/tqdm
parentdev-python/webob: Bump to 1.8.7 (diff)
downloadgentoo-5ce9807c146a92d4a4ea2a266dec32b09a91ec6c.tar.gz
gentoo-5ce9807c146a92d4a4ea2a266dec32b09a91ec6c.tar.bz2
gentoo-5ce9807c146a92d4a4ea2a266dec32b09a91ec6c.zip
dev-python/tqdm: Bump to 4.57.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.57.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 94caac801d32..b684a5ce5c7a 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -4,3 +4,4 @@ DIST tqdm-4.55.2.tar.gz 162632 BLAKE2B 02e49f442c8d5ad3799de143dd8a188796293253e
DIST tqdm-4.56.0.tar.gz 166848 BLAKE2B d2239ff7efd9c91b7101357b6c7d352c42c49c41c34209092fdfe420e090458581aed61f2ddff09d1c64539eed0d83eb240e6b467b82193016cf13bac94f3313 SHA512 c65eb167063c4b6a0931a6f19fb2e4d88eb92fe3f3118c0247cd0e148220523097c4419289428d2a4c22cc187011d78cba32fc080eb2cbe352f873e29646094e
DIST tqdm-4.56.1.tar.gz 166899 BLAKE2B 11c40049ee2d3ce890a6a443432fd2834b177ea4d19549c179dcc9da6bcd71093b54a5f2a7027ab40e9c5c7bf48581c7fe4cd4ad819a3d60a8e3c7c5537fd357 SHA512 4b940bbf2fdd1093e1e0c50f17de7231dd58b0f04d9a8a97df4835f23e46b7b58f68e1ad96f77b191cae49e80498fd31ae67ff4fb4db821d90ec85bf83d48043
DIST tqdm-4.56.2.tar.gz 167040 BLAKE2B c1754cb262977688365c6bf17ec6b6ec31704cdb22aaf05261653c4c9609bdbd16863a15f58a7fe0fb2c0983513b091be55dbca48a0a7b1177a4d017d6800ce0 SHA512 8e7ec199c43a3cdb69bdbfaaec33c11ce8b337255eff4ae6af9928c2a2c5adb065698538562020c9f0a29a63671cbbfcf2c4c9ccb25bec0ec1d8ae8df66516c3
+DIST tqdm-4.57.0.tar.gz 167590 BLAKE2B 30852febdcb69d1f0c6a7416ec7611a79896d643e18c658bb19e52196b4998d8ff9ef708c92d09d9804d8c0210b378dc8a3d58ef2b788a65835cd95ddf3406e4 SHA512 5393ffe6cbb5b41a3c51efdd14169936fcae9dd635b7a35d64f44157f2c855914dbd5c8aa933c4830a16867c83a73c0734e0ebee548392d2c73cae4e6aba531f
diff --git a/dev-python/tqdm/tqdm-4.57.0.ebuild b/dev-python/tqdm/tqdm-4.57.0.ebuild
new file mode 100644
index 000000000000..0bf4e4570b83
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.57.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}