summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-29 11:09:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-29 11:16:20 +0200
commit9ff045857df40800afddbadd83e45e2e42288e48 (patch)
tree2877604e2cbf2d1dc74fa53ca077bcf6fda6d8d4 /dev-python/urwid_readline/urwid_readline-0.13.ebuild
parentdev-util/stripe-mock: Bump to 0.113.0 (diff)
downloadgentoo-9ff045857df40800afddbadd83e45e2e42288e48.tar.gz
gentoo-9ff045857df40800afddbadd83e45e2e42288e48.tar.bz2
gentoo-9ff045857df40800afddbadd83e45e2e42288e48.zip
dev-python/urwid_readline: New dep of dev-python/pudb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/urwid_readline/urwid_readline-0.13.ebuild')
-rw-r--r--dev-python/urwid_readline/urwid_readline-0.13.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/urwid_readline/urwid_readline-0.13.ebuild b/dev-python/urwid_readline/urwid_readline-0.13.ebuild
new file mode 100644
index 000000000000..8a88a108b0b5
--- /dev/null
+++ b/dev-python/urwid_readline/urwid_readline-0.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Text input widget for urwid that supports readline shortcuts"
+HOMEPAGE="
+ https://github.com/rr-/urwid_readline/
+ https://pypi.org/project/urwid-readline/"
+SRC_URI="
+ https://github.com/rr-/urwid_readline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest