summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-21 05:31:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-21 05:31:06 +0100
commit5bbb4d25138629d5bf80f66af605a01cffe32a71 (patch)
tree88fe1486ee4d1146beacb47d2f9f7ddd6f200be1 /dev-python/wcmatch
parentdev-python/coverage: Bump to 7.4.2 (diff)
downloadgentoo-5bbb4d25138629d5bf80f66af605a01cffe32a71.tar.gz
gentoo-5bbb4d25138629d5bf80f66af605a01cffe32a71.tar.bz2
gentoo-5bbb4d25138629d5bf80f66af605a01cffe32a71.zip
dev-python/wcmatch: Bump to 8.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/wcmatch-8.5.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index d4cd5b88324f..e56e0d2e7a89 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1 +1,2 @@
+DIST wcmatch-8.5.1.gh.tar.gz 117483 BLAKE2B db4d77651ab4fc6692c746d94dda68dc0fcdfe72a6e3b512b4f60a1bd5bf7015e21349d022c6ec17ea2bbc55ae87cf6c9a3690d9b6774f02a167b4b0ad65b691 SHA512 10ab7d76ad7c71efb2639e2d439593a45339f485f1f628770ae845c291c34d0e3fc8a9b75b6ce6d3c131c1f0a521f3aafcadc7d24ffad5284e9db06dc5838974
DIST wcmatch-8.5.gh.tar.gz 117301 BLAKE2B db62057e9fe148d64a7b326ba15029a20781008288a60171793db3e4e3aab75ca4eeb1be63b7c2af5951225d512d4a5886982cb278c703980b755e6b816e51bf SHA512 a4de7714945e36e0ac68c5ce99cc06887fdceb3a461464ceb05e66f5a84965cafa9cdac337e3332f5fe42aaef90d53978185e451b28d56730418ca830f98c290
diff --git a/dev-python/wcmatch/wcmatch-8.5.1.ebuild b/dev-python/wcmatch/wcmatch-8.5.1.ebuild
new file mode 100644
index 000000000000..67f86264c16d
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.5.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}