summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-11 18:06:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-11 18:42:09 +0100
commit339cd9c1db9a5af9e928f8a474786c3d6f68054a (patch)
tree253c5e994368fbf820db5702d3a960de6d9e3f32 /dev-python/weasyprint
parentdev-python/reportlab: Bump to 4.0.8 (diff)
downloadgentoo-339cd9c1db9a5af9e928f8a474786c3d6f68054a.tar.gz
gentoo-339cd9c1db9a5af9e928f8a474786c3d6f68054a.tar.bz2
gentoo-339cd9c1db9a5af9e928f8a474786c3d6f68054a.zip
dev-python/weasyprint: Bump to 60.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-60.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 4f6fdac581a0..55f459970c05 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-60.1.tar.gz 441148 BLAKE2B 3d5eb6d9dd80a222649a03e09a096786bc4add67c7df3965325217a4c03aa4a545d442b6327b83bea082fa50f5d1ba32587749449824267acc849a0374a58cea SHA512 7fc05c6c80fc6eb251637b529720794df4b7d5c066ecfb4086cb49b7e1c42a51fcb7b2502a79f9f01f6cc5b83d92d5a48c7386b2db555e7dba6eb64e3151d6ae
+DIST weasyprint-60.2.tar.gz 442554 BLAKE2B 492f0cd3f155aa20e440e384930cff38e8674cc2430f134fdcce80e627997b0d752d6b585aaece6ff23505fed3ff45430c06c82763ca96ce30da38411e21721f SHA512 1da30b2626911c22a996cf7888edc86a7e3534d552325790c3bb06b29a7bedda8021680f5cac1acd6f0aba0658c64cda02cafa1fcba5f3a76bce6bb5fb229b71
diff --git a/dev-python/weasyprint/weasyprint-60.2.ebuild b/dev-python/weasyprint/weasyprint-60.2.ebuild
new file mode 100644
index 000000000000..458a0382bcaf
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-60.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest