summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 07:40:33 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 10:23:13 +0200
commitccfb3a01705fb6203bfef8308401908832a1e610 (patch)
treedc38fa4093178940297b4bf22697313923b25d69 /dev-python/websocket-client
parentdev-python/jsonref: add 1.0.1 (diff)
downloadgentoo-ccfb3a01705fb6203bfef8308401908832a1e610.tar.gz
gentoo-ccfb3a01705fb6203bfef8308401908832a1e610.tar.bz2
gentoo-ccfb3a01705fb6203bfef8308401908832a1e610.zip
dev-python/websocket-client: add 1.4.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/websocket-client')
-rw-r--r--dev-python/websocket-client/Manifest1
-rw-r--r--dev-python/websocket-client/websocket-client-1.4.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/websocket-client/Manifest b/dev-python/websocket-client/Manifest
index 29fca145bd15..8cfdbff4718a 100644
--- a/dev-python/websocket-client/Manifest
+++ b/dev-python/websocket-client/Manifest
@@ -1 +1,2 @@
DIST websocket-client-1.4.1.tar.gz 50883 BLAKE2B 4d80b5d5f407fdd81b5468f37b66759970cf96395738b67271388c55d13c30c36c9f7a5a89b10fb78bde4870e25bea5761c297b3fc85b0b8d62eda24443421d9 SHA512 a2804421e97ccbfb61cb2e8a2be6ecd5d5d60210971e27ca4e00a4854fb49df2e3c87ec87c0ec11565d7ce03f419dc3cbd8c2402843a8fced49d75d65d07b502
+DIST websocket-client-1.4.2.tar.gz 49113 BLAKE2B d1d25d7066512ae5a8fa189b22ad320331b3d34e6ae953a29b7b5644065a9d60ffd6743bae6e769f356b7294374690fba103ee42ed59f5f9b213dfeda7f038af SHA512 4003a6b387096a738e9b9f76129b954bbc208b8b75c6ba9d6f0dade82078645109f985164ce25c1a600e630833f7187d51d6236997d6c72315d206e91f1aae7a
diff --git a/dev-python/websocket-client/websocket-client-1.4.2.ebuild b/dev-python/websocket-client/websocket-client-1.4.2.ebuild
new file mode 100644
index 000000000000..78665da331ef
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="
+ https://github.com/websocket-client/websocket-client/
+ https://pypi.org/project/websocket-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}