summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-28 13:57:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-28 14:03:54 +0200
commitf6524f4a6975fa393f32b0bbee4390df0e34fc88 (patch)
tree55aad45a6a78cd14287c2680897de79859ca72b7 /dev-python/webtest
parentdev-python/tox: Remove old (diff)
downloadgentoo-f6524f4a6975fa393f32b0bbee4390df0e34fc88.tar.gz
gentoo-f6524f4a6975fa393f32b0bbee4390df0e34fc88.tar.bz2
gentoo-f6524f4a6975fa393f32b0bbee4390df0e34fc88.zip
dev-python/webtest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest1
-rw-r--r--dev-python/webtest/files/webtest-3.0.0-python3.12-unittest.patch115
-rw-r--r--dev-python/webtest/webtest-3.0.0-r1.ebuild47
3 files changed, 0 insertions, 163 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index 270b5b8df17d..716602b342d6 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -1,2 +1 @@
-DIST WebTest-3.0.0.tar.gz 75871 BLAKE2B e97d050c1077d74e463e3409580d021424f755933bb9d5ac5e119c70c76890d5632e565f03a02f3497e21fed95158c56b199a877fc4575968f6b4af2655db8b6 SHA512 b97a6311d7e3bf653bec93c2390fb75c991d0dea6148680d8b6ff87861c130518a5d150dd157eab9b032b278566ad12c0ac8f5fc2ddbeba31e35de1e1f06f747
DIST webtest-3.0.1.tar.gz 79278 BLAKE2B 3466e0d291cc8b02f5f11c8174dcf99cf56696d394de195fce721bb4f01cb76140bf39a955a264f84daad091ad8c37b6302e39c351373b77c4ec0d8a40d74575 SHA512 58417f2d533bd8339258f756d16d1f1cf26f89d8bc387cc7a7ba8fa2b30346454c053b531f79238939112b318fe1972d960d681c605e178d223acc53a8784be4
diff --git a/dev-python/webtest/files/webtest-3.0.0-python3.12-unittest.patch b/dev-python/webtest/files/webtest-3.0.0-python3.12-unittest.patch
deleted file mode 100644
index c797a8cbb0c9..000000000000
--- a/dev-python/webtest/files/webtest-3.0.0-python3.12-unittest.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-https://github.com/Pylons/webtest/pull/251
-
-From d82ec5bd2cf3c7109a1d49ad9fa802ae1eae1763 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 29 May 2023 15:54:28 +0100
-Subject: [PATCH] Replace deprecated unittest aliases for Python 3.12
-
-See https://docs.python.org/3.12/whatsnew/3.12.html#removed.
---- a/tests/test_app.py
-+++ b/tests/test_app.py
-@@ -221,7 +221,7 @@ def cookie_app(environ, start_response):
- ('Set-Cookie', 'foo=bar;baz'),
- ])
- else:
-- self.assertEquals(dict(req.cookies),
-+ self.assertEqual(dict(req.cookies),
- {'spam': 'eggs', 'foo': 'bar'})
- self.assertIn('foo=bar', environ['HTTP_COOKIE'])
- self.assertIn('spam=eggs', environ['HTTP_COOKIE'])
-@@ -258,7 +258,7 @@ def cookie_app(environ, start_response):
- ('Set-Cookie', 'foo=bar;baz; secure'),
- ])
- else:
-- self.assertEquals(dict(req.cookies),
-+ self.assertEqual(dict(req.cookies),
- {'spam': 'eggs', 'foo': 'bar'})
- self.assertIn('foo=bar', environ['HTTP_COOKIE'])
- self.assertIn('spam=eggs', environ['HTTP_COOKIE'])
---- a/tests/test_authorisation.py
-+++ b/tests/test_authorisation.py
-@@ -17,7 +17,7 @@ def test_basic_authorization(self):
- app.authorization = authorization
-
- self.assertIn('HTTP_AUTHORIZATION', app.extra_environ)
-- self.assertEquals(app.authorization, authorization)
-+ self.assertEqual(app.authorization, authorization)
-
- resp = app.get('/')
- resp.mustcontain('HTTP_AUTHORIZATION: Basic Z2F3ZWw6cGFzc3dk')
-@@ -26,7 +26,7 @@ def test_basic_authorization(self):
- authtype, value = header.split(' ')
- auth = (authtype,
- b64decode(to_bytes(value)).decode('latin1').split(':'))
-- self.assertEquals(authorization, auth)
-+ self.assertEqual(authorization, auth)
-
- app.authorization = None
- self.assertNotIn('HTTP_AUTHORIZATION', app.extra_environ)
-@@ -37,7 +37,7 @@ def test_bearer_authorization(self):
- app.authorization = authorization
-
- self.assertIn('HTTP_AUTHORIZATION', app.extra_environ)
-- self.assertEquals(app.authorization, authorization)
-+ self.assertEqual(app.authorization, authorization)
-
- resp = app.get('/')
- resp.mustcontain('HTTP_AUTHORIZATION: Bearer 2588409761fcfa3e378bff4fb766e2e2')
---- a/tests/test_forms.py
-+++ b/tests/test_forms.py
-@@ -1031,7 +1031,7 @@ def test_upload_invalid_content(self):
- single_form.submit("button")
- except ValueError:
- e = sys.exc_info()[1]
-- self.assertEquals(
-+ self.assertEqual(
- str(e),
- u('File content must be %s not %s' % (bytes, int))
- )
---- a/tests/test_lint.py
-+++ b/tests/test_lint.py
-@@ -62,15 +62,15 @@ class TestMiddleware(unittest.TestCase):
- @unittest.skipIf(sys.flags.optimize > 0, "skip assert tests if optimize is enabled")
- def test_lint_too_few_args(self):
- linter = middleware(application)
-- with self.assertRaisesRegexp(AssertionError, "Two arguments required"):
-+ with self.assertRaisesRegex(AssertionError, "Two arguments required"):
- linter()
-- with self.assertRaisesRegexp(AssertionError, "Two arguments required"):
-+ with self.assertRaisesRegex(AssertionError, "Two arguments required"):
- linter({})
-
- @unittest.skipIf(sys.flags.optimize > 0, "skip assert tests if optimize is enabled")
- def test_lint_no_keyword_args(self):
- linter = middleware(application)
-- with self.assertRaisesRegexp(AssertionError, "No keyword arguments "
-+ with self.assertRaisesRegex(AssertionError, "No keyword arguments "
- "allowed"):
- linter({}, 'foo', baz='baz')
-
-@@ -82,7 +82,7 @@ def test_lint_no_keyword_args(self):
- def test_lint_iterator_returned(self):
- linter = middleware(lambda x, y: None) # None is not an iterator
- msg = "The application must return an iterator, if only an empty list"
-- with self.assertRaisesRegexp(AssertionError, msg):
-+ with self.assertRaisesRegex(AssertionError, msg):
- linter({'wsgi.input': 'foo', 'wsgi.errors': 'foo'}, 'foo')
-
-
-@@ -109,13 +109,13 @@ def test_close(self):
- def test_iter(self):
- data = to_bytes("A line\nAnother line\nA final line\n")
- input_wrapper = InputWrapper(BytesIO(data))
-- self.assertEquals(to_bytes("").join(input_wrapper), data, '')
-+ self.assertEqual(to_bytes("").join(input_wrapper), data, '')
-
- def test_seek(self):
- data = to_bytes("A line\nAnother line\nA final line\n")
- input_wrapper = InputWrapper(BytesIO(data))
- input_wrapper.seek(0)
-- self.assertEquals(to_bytes("").join(input_wrapper), data, '')
-+ self.assertEqual(to_bytes("").join(input_wrapper), data, '')
-
-
- class TestMiddleware2(unittest.TestCase):
-
diff --git a/dev-python/webtest/webtest-3.0.0-r1.ebuild b/dev-python/webtest/webtest-3.0.0-r1.ebuild
deleted file mode 100644
index 24da904ad073..000000000000
--- a/dev-python/webtest/webtest-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN="WebTest"
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="
- https://docs.pylonsproject.org/projects/webtest/en/latest/
- https://github.com/Pylons/webtest/
- https://pypi.org/project/WebTest/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/paste[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/legacy-cgi[${PYTHON_USEDEP}]
- ' 3.13)
- )
-"
-
-PATCHES=(
- "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
- "${FILESDIR}/webtest-3.0.0-python3.12-unittest.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest