summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-27 01:47:12 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-27 02:00:21 -0500
commit2ca17dda3c13e863fb5047753c4a58890ef65579 (patch)
tree910774ecfa41fe3ecba7452385ec3b9fbe3d4971 /dev-python/wstools/wstools-0.4.5-r1.ebuild
parentmedia-gfx/pycam: Removed old version (diff)
downloadgentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.tar.gz
gentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.tar.bz2
gentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.zip
dev-python/wstools: add py36 support, fix deps, and enable test phase
Also, re-add all the dropped keywords due to the previously added, unnecessary deps.
Diffstat (limited to 'dev-python/wstools/wstools-0.4.5-r1.ebuild')
-rw-r--r--dev-python/wstools/wstools-0.4.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/wstools/wstools-0.4.5-r1.ebuild b/dev-python/wstools/wstools-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..9a3d508f201b
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_test() {
+ esetup.py test
+}