summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 04:41:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 04:41:25 +0200
commit91bd41145a0f6e932339ce158ea79f88d26ced89 (patch)
tree5b5eabee55c3be0c59a839447103923edb9cf478 /dev-python/xdoctest
parentdev-python/aesara: Bump to 2.9.3 (diff)
downloadgentoo-91bd41145a0f6e932339ce158ea79f88d26ced89.tar.gz
gentoo-91bd41145a0f6e932339ce158ea79f88d26ced89.tar.bz2
gentoo-91bd41145a0f6e932339ce158ea79f88d26ced89.zip
dev-python/xdoctest: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 3ae9143a8daa..d86c33fb3d9f 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-1.1.1.gh.tar.gz 212973 BLAKE2B 2af66b23889ba1f0321af08fbb81cec87f6c582fe000eaa3372f166287bf69b40fd82eff1029aadb0d0d62760640881676f61571f0bed37309a98680450fbe77 SHA512 8b0f77df54be8e61bf1b98bbc6ef7ac76337e634ea590394e13481c61ea83b6b4b017588f8d6ab813f95d277f605ece2d82441d6cbd25bbf485dd5bc85677abd
+DIST xdoctest-1.1.2.gh.tar.gz 225392 BLAKE2B 6a140197244f362b65047b7f181b3682aa7cf65c2f103e22f277388b6fecdf4894ed7c04e24cf08be1ecf78c0957fb04dbe4f97d894761ba7a47476b3eaf867c SHA512 9119c7895890b0369fd353aa2245fc4632004aca9be5086051f16de5abe0e596ee09cfedaa13b16a408aa98b81045d38e6e4df8b60197d66aec7b5e73709237d
diff --git a/dev-python/xdoctest/xdoctest-1.1.2.ebuild b/dev-python/xdoctest/xdoctest-1.1.2.ebuild
new file mode 100644
index 000000000000..5a3da3c3559a
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}